summaryrefslogtreecommitdiffstats
path: root/graphics/dia/dia.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dia/dia.SlackBuild')
-rw-r--r--graphics/dia/dia.SlackBuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index cc383f7eb5..fad89df44a 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -3,18 +3,17 @@
# Slackware build script for dia
# Written by Matt Hayes (dominian@slackadelic.com
# Updated for 64bit by Ash Wiren (ash@spooksoftware.com 19-08-2009
+# Currently mantained by Dugan Chen (dugan [underscore] c [at] fastmail [dot] fm)))
PRGNAM=dia
-VERSION=0.97
+VERSION=0.97.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -49,8 +48,8 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# Fixup the fr mandir
-patch -p1 < $CWD/dia-0.97-fixup_fr_mandir.patch
+# Fix the location of the French manpages.
+sed -i 's/$(datadir)\/man/@mandir@/' doc/fr/Makefile.in
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -67,14 +66,12 @@ make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# docdir already exists :-)
cp -a \
- AUTHORS COPYING ChangeLog KNOWN_BUGS MAINTAINERS NEWS README THANKS TODO \
+ AUTHORS COPYING ChangeLog ChangeLog.pre-git KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild