summaryrefslogtreecommitdiffstats
path: root/graphics/brlcad/brlcad.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/brlcad/brlcad.SlackBuild')
-rw-r--r--graphics/brlcad/brlcad.SlackBuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/graphics/brlcad/brlcad.SlackBuild b/graphics/brlcad/brlcad.SlackBuild
index 044504a454..2e8ecc9f77 100644
--- a/graphics/brlcad/brlcad.SlackBuild
+++ b/graphics/brlcad/brlcad.SlackBuild
@@ -6,10 +6,10 @@
# Released under the WTFPL - http://sam.zoy.org/wtfpl/
# Maintained as of version 7.16.6 by Niels Horn <niels.horn@gmail.com>
-# Revision date: 2010/08/26
+# Revision date: 2011/03/29
PRGNAM=brlcad
-VERSION=${VERSION:-7.16.10}
+VERSION=${VERSION:-7.18.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,6 +55,13 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Don't be too "strict" with src/conv/patch/patch-g.c
+# This is a "known issue" according to the guys on #brlcad so let's try
+# to remove this with the next release.
+# Another solution is to completely disable "strict building" with the
+# configure flag "-disable-strict-build"
+sed -i "/patch_g_CFLAGS/s|\${STRICT_FLAGS}||" src/conv/Makefile.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -85,17 +92,18 @@ chmod 0755 $PKG/etc/profile.d/*
# Copy icon & desktop file to package
mkdir -p $PKG/usr/share/{applications,pixmaps}
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+cat $CWD/${PRGNAM}_mged.desktop > $PKG/usr/share/applications/${PRGNAM}_mged.desktop
+cat $CWD/${PRGNAM}_archer.desktop > $PKG/usr/share/applications/${PRGNAM}_archer.desktop
cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
-( cd $PKG/usr/doc/$PRGNAM-$VERSION
+cd $PKG/usr/doc/$PRGNAM-$VERSION
for sub in doc html; do
ln -s ../../../opt/$PRGNAM/share/$PRGNAM/$VERSION/$sub
done
-)
+cd -
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc