summaryrefslogtreecommitdiffstats
path: root/graphics/ART/disable_mimalloc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ART/disable_mimalloc.patch')
-rw-r--r--graphics/ART/disable_mimalloc.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/ART/disable_mimalloc.patch b/graphics/ART/disable_mimalloc.patch
new file mode 100644
index 0000000000..c77763ed12
--- /dev/null
+++ b/graphics/ART/disable_mimalloc.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt 2023-01-16 02:54:14.000000000 -0500
++++ CMakeLists.txt.new 2023-02-10 23:26:49.042916996 -0500
+@@ -606,8 +606,6 @@
+ add_definitions(-DWITH_MIMALLOC)
+ set(ART_MIMALLOC_VERSION_INFO "V${mimalloc_VERSION}")
+ endif()
+-else()
+- message(FATAL_ERROR "ART requires the mimalloc library. Please install it (see https://microsoft.github.io/mimalloc/)")
+ endif()
+
+ if(ENABLE_LIBRAW)