summaryrefslogtreecommitdiffstats
path: root/gis/python3-xarray/python3-xarray.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/python3-xarray/python3-xarray.SlackBuild')
-rw-r--r--gis/python3-xarray/python3-xarray.SlackBuild32
1 files changed, 10 insertions, 22 deletions
diff --git a/gis/python3-xarray/python3-xarray.SlackBuild b/gis/python3-xarray/python3-xarray.SlackBuild
index b207e37591..92d7f121e6 100644
--- a/gis/python3-xarray/python3-xarray.SlackBuild
+++ b/gis/python3-xarray/python3-xarray.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-xarray
# Copyright 2018-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2022-2024 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-xarray
-VERSION=${VERSION:-2022.03.0}
+VERSION=${VERSION:-2024.03.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -53,20 +53,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,19 +63,21 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CITATION.cff CODE_OF_CONDUCT.md CONTRIBUTING.md HOW_TO_RELEASE.md LICENSE README.rst \
+ CITATION.cff CODE_OF_CONDUCT.md CONTRIBUTING.md HOW_TO_RELEASE.md LICENSE README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild