summaryrefslogtreecommitdiffstats
path: root/gis/pyproj/pyproj.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/pyproj/pyproj.SlackBuild')
-rw-r--r--gis/pyproj/pyproj.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/gis/pyproj/pyproj.SlackBuild b/gis/pyproj/pyproj.SlackBuild
index 1f55484da7..62bb864a1a 100644
--- a/gis/pyproj/pyproj.SlackBuild
+++ b/gis/pyproj/pyproj.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyproj
-# Copyright 2013 Benjamin Trigona-Harany
+# Copyright 2013-2018 Benjamin Trigona-Harany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyproj
-VERSION=${VERSION:-1.9.5.1}
+VERSION=${VERSION:-1.9.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,10 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true