summaryrefslogtreecommitdiffstats
path: root/gis/pgrouting/pgrouting.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/pgrouting/pgrouting.SlackBuild')
-rw-r--r--gis/pgrouting/pgrouting.SlackBuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/gis/pgrouting/pgrouting.SlackBuild b/gis/pgrouting/pgrouting.SlackBuild
index 1d9a256a77..81c926b9fd 100644
--- a/gis/pgrouting/pgrouting.SlackBuild
+++ b/gis/pgrouting/pgrouting.SlackBuild
@@ -2,6 +2,7 @@
# SlackBuild script for pgRouting
+# Copyright 2024 Giancarlo Dessi, Cagliari, IT
# Copyright 2013-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -27,7 +28,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pgrouting
-VERSION=${VERSION:-3.1.3}
+VERSION=${VERSION:-3.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,6 +79,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Prevent cmake warnings in current
+if [ -d /usr/share/cmake-3.28 ]; then
+ CMAKE_POLICY="-DCMAKE_POLICY_DEFAULT_CMP0148=OLD "
+ sed -i ./CMakeLists.txt -e "s/VERSION 3.2 FATAL_ERROR/VERSION 3.5 FATAL_ERROR/g"
+else
+ CMAKE_POLICY=""
+fi
+
mkdir -p build
cd build
cmake \
@@ -88,7 +94,8 @@ cd build
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_DOC=${WITH_DOC:-OFF} \
- ..
+ $CMAKE_POLICY \
+ -DCMAKE_BUILD_TYPE=Release ..
make all doc
make install DESTDIR=$PKG