summaryrefslogtreecommitdiffstats
path: root/games/xonotic
diff options
context:
space:
mode:
Diffstat (limited to 'games/xonotic')
-rw-r--r--games/xonotic/0d3d1f2655901776b2fc3e911eb78478412f789a.diff31
-rw-r--r--games/xonotic/README10
-rw-r--r--games/xonotic/gcc11.diff89
-rw-r--r--games/xonotic/xonotic-sdl.desktop8
-rw-r--r--games/xonotic/xonotic.SlackBuild41
-rw-r--r--games/xonotic/xonotic.info8
6 files changed, 40 insertions, 147 deletions
diff --git a/games/xonotic/0d3d1f2655901776b2fc3e911eb78478412f789a.diff b/games/xonotic/0d3d1f2655901776b2fc3e911eb78478412f789a.diff
deleted file mode 100644
index 46556db5db..0000000000
--- a/games/xonotic/0d3d1f2655901776b2fc3e911eb78478412f789a.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index d21887d..07338eb 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -5,7 +5,7 @@ blind_id_SOURCES = main.c
- blind_id_LDADD = libd0_blind_id.la
-
- lib_LTLIBRARIES = libd0_blind_id.la
--# versioninfo:
-+# version-info:
- # - compatible interface change: c:r:a -> c+1:0:a+1
- # - incompatible interface change: c:r:a -> c+1:0:0
- # - internal change: c:r:a -> c:r+1:a
-@@ -29,7 +29,7 @@ libd0_blind_id_la_SOURCES += d0_bignum-gmp.c
- endif
- endif
- endif
--libd0_blind_id_la_LDFLAGS = -versioninfo 7:1:7
-+libd0_blind_id_la_LDFLAGS = -version-info 7:1:7
- libd0_blind_id_la_CFLAGS = -fvisibility=hidden -Wold-style-definition -Wstrict-prototypes -Wsign-compare -Wdeclaration-after-statement
- library_includedir = $(includedir)/d0_blind_id
- library_include_HEADERS = d0_blind_id.h d0.h
-@@ -40,7 +40,7 @@ if ENABLE_RIJNDAEL
- lib_LTLIBRARIES += libd0_rijndael.la
- libd0_rijndael_la_SOURCES = d0_rijndael.c \
- d0_rijndael.h
--libd0_rijndael_la_LDFLAGS = -versioninfo 0:0:0
-+libd0_rijndael_la_LDFLAGS = -version-info 0:0:0
- libd0_rijndael_la_CFLAGS = -fvisibility=hidden -Wold-style-definition -Wstrict-prototypes -Wsign-compare -Wdeclaration-after-statement
- library_include_HEADERS += d0_rijndael.h
- pkgconfig_HEADERS += d0_rijndael.pc
diff --git a/games/xonotic/README b/games/xonotic/README
index 0611d9c7e6..c51e063195 100644
--- a/games/xonotic/README
+++ b/games/xonotic/README
@@ -4,3 +4,13 @@ addictive arena shooter gameplay which is all spawned and driven by
the community itself. Xonotic is a direct successor of the Nexuiz
project with years of development between them, and it aims to become
the best possible open-source FPS (first-person-shooter) of its kind.
+
+Note: package now includes the dedicated server.
+
+To start a dedicater server:
+ - copy doc/server/server.cfg to ~/.xonotic/data/server.cfg
+ - edit cfg according to your needs
+ - start server via 'xonotic-dedicated'
+
+For server configuration check out the wiki's server section:
+https://gitlab.com/xonotic/xonotic/-/wikis/home#server-administration
diff --git a/games/xonotic/gcc11.diff b/games/xonotic/gcc11.diff
deleted file mode 100644
index fd8cb99481..0000000000
--- a/games/xonotic/gcc11.diff
+++ /dev/null
@@ -1,89 +0,0 @@
---- a/dpsoftrast.c 2013-02-07 11:40:40.000000000 +0000
-+++ a/dpsoftrast.c 2021-04-30 04:45:31.276607019 +0000
-@@ -21,6 +21,7 @@
- #if defined(__APPLE__)
- #include <libkern/OSAtomic.h>
- #define ALIGN(var) var __attribute__((__aligned__(16)))
-+ #define ALIGN_STRUCT(def) struct __attribute__((__aligned__(16))) def
- #define ATOMIC(var) var __attribute__((__aligned__(4)))
- #define MEMORY_BARRIER (_mm_sfence())
- #define ATOMIC_COUNTER volatile int32_t
-@@ -29,6 +30,7 @@
- #define ATOMIC_ADD(counter, val) ((void)OSAtomicAdd32Barrier((val), &(counter)))
- #elif defined(__GNUC__) && defined(WIN32)
- #define ALIGN(var) var __attribute__((__aligned__(16)))
-+ #define ALIGN_STRUCT(def) struct __attribute__((__aligned__(16))) def
- #define ATOMIC(var) var __attribute__((__aligned__(4)))
- #define MEMORY_BARRIER (_mm_sfence())
- //(__sync_synchronize())
-@@ -43,6 +45,7 @@
- #define ATOMIC_ADD(counter, val) ((void)InterlockedExchangeAdd((LONG *) &(counter), (val)))
- #elif defined(__GNUC__)
- #define ALIGN(var) var __attribute__((__aligned__(16)))
-+ #define ALIGN_STRUCT(def) struct __attribute__((__aligned__(16))) def
- #define ATOMIC(var) var __attribute__((__aligned__(4)))
- #define MEMORY_BARRIER (_mm_sfence())
- //(__sync_synchronize())
-@@ -52,6 +55,7 @@
- #define ATOMIC_ADD(counter, val) ((void)__sync_fetch_and_add(&(counter), (val)))
- #elif defined(_MSC_VER)
- #define ALIGN(var) __declspec(align(16)) var
-+ #define ALIGN_STRUCT(def) ALIGN(struct def)
- #define ATOMIC(var) __declspec(align(4)) var
- #define MEMORY_BARRIER (_mm_sfence())
- //(MemoryBarrier())
-@@ -65,6 +69,9 @@
- #ifndef ALIGN
- #define ALIGN(var) var
- #endif
-+#ifndef ALIGN_STRUCT
-+#define ALIGN_STRUCT(def) def
-+#endif
- #ifndef ATOMIC
- #define ATOMIC(var) var
- #endif
-@@ -163,7 +170,7 @@
- #define DPSOFTRAST_DRAW_MAXCOMMANDPOOL 2097152
- #define DPSOFTRAST_DRAW_MAXCOMMANDSIZE 16384
-
--typedef ALIGN(struct DPSOFTRAST_State_Command_Pool_s
-+typedef ALIGN_STRUCT(DPSOFTRAST_State_Command_Pool_s
- {
- int freecommand;
- int usedcommands;
-@@ -171,7 +178,7 @@
- }
- DPSOFTRAST_State_Command_Pool);
-
--typedef ALIGN(struct DPSOFTRAST_State_Triangle_s
-+typedef ALIGN_STRUCT(DPSOFTRAST_State_Triangle_s
- {
- unsigned char mip[DPSOFTRAST_MAXTEXTUREUNITS]; // texcoord to screen space density values (for picking mipmap of textures)
- float w[3];
-@@ -198,7 +205,7 @@
-
- #define DPSOFTRAST_DRAW_MAXSUBSPAN 16
-
--typedef ALIGN(struct DPSOFTRAST_State_Span_s
-+typedef ALIGN_STRUCT(DPSOFTRAST_State_Span_s
- {
- int triangle; // triangle this span was generated by
- int x; // framebuffer x coord
-@@ -236,7 +243,7 @@
- }
- DPSOFTRAST_BLENDMODE;
-
--typedef ALIGN(struct DPSOFTRAST_State_Thread_s
-+typedef ALIGN_STRUCT(DPSOFTRAST_State_Thread_s
- {
- void *thread;
- int index;
-@@ -302,7 +309,7 @@
- }
- DPSOFTRAST_State_Thread);
-
--typedef ALIGN(struct DPSOFTRAST_State_s
-+typedef ALIGN_STRUCT(DPSOFTRAST_State_s
- {
- int fb_width;
- int fb_height;
diff --git a/games/xonotic/xonotic-sdl.desktop b/games/xonotic/xonotic-sdl.desktop
new file mode 100644
index 0000000000..fe5b8e4832
--- /dev/null
+++ b/games/xonotic/xonotic-sdl.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Xonotic (SDL)
+Categories=Game;
+Exec=xonotic-sdl
+Icon=xonotic
+Terminal=false
+StartupNotify=false
diff --git a/games/xonotic/xonotic.SlackBuild b/games/xonotic/xonotic.SlackBuild
index d0b41d0f5e..5c08a58476 100644
--- a/games/xonotic/xonotic.SlackBuild
+++ b/games/xonotic/xonotic.SlackBuild
@@ -22,13 +22,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 20220221 bkw: Modified by SlackBuilds.org: fix build on 15.0.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xonotic
-VERSION=${VERSION:-0.8.2}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-0.8.6}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -75,26 +73,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p \
$PKG/usr/bin \
$PKG/usr/share/$PRGNAM \
$PKG/usr/share/{applications,pixmaps}
-# Fix -version-info as requested by Hunter Sezen
-patch -p1 < $CWD/0d3d1f2655901776b2fc3e911eb78478412f789a.diff source/d0_blind_id/Makefile.am
-
-# 20220221 bkw: fix compile with gcc 11. patch came from:
-# https://bugs.gentoo.org/show_bug.cgi?id=786288
-cd source/darkplaces
-patch -p1 < $CWD/gcc11.diff
-cd -
-
cd source/d0_blind_id
- autoreconf -fi
+ ./autogen.sh
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -103,7 +92,7 @@ cd source/d0_blind_id
--disable-static
make
- make install DESTDIR=$PKG
+ make install-strip DESTDIR=$PKG
cd -
# Rather than using libdl, link libd0_blind_id and libd0_rijndael
@@ -115,20 +104,26 @@ make -C source/darkplaces release \
CFLAGS_CRYPTO_RIJNDAEL="-I$PKG/usr/include -DCRYPTO_RIJNDAEL_STATIC" \
LIB_CRYPTO_RIJNDAEL="-L$PKG/usr/lib${LIBDIRSUFFIX} -ld0_rijndael"
-install -m 755 source/darkplaces/darkplaces-sdl $PKG/usr/bin/xonotic-glx
-install -m 755 source/darkplaces/darkplaces-glx $PKG/usr/bin/xonotic-sdl
-install -m 644 $CWD/xonotic.desktop $PKG/usr/share/applications
+install -m 755 source/darkplaces/darkplaces-sdl $PKG/usr/bin/xonotic-sdl
+install -m 755 source/darkplaces/darkplaces-glx $PKG/usr/bin/xonotic-glx
+install -m 755 source/darkplaces/darkplaces-dedicated $PKG/usr/bin/xonotic-dedicated
+install -m 644 $CWD/*.desktop $PKG/usr/share/applications
install -m 644 misc/logos/xonotic_icon.svg $PKG/usr/share/pixmaps/xonotic.svg
cp -a data key_0.d0pk $PKG/usr/share/$PRGNAM
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/server
cp -a \
- COPYING Docs/* \
+ COPYING Docs/*.txt Docs/egyptsoc Docs/faq.md Docs/guide.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-rm -f $PKG/usr/lib*/*.la
+# Copy dedicated server related files
+cp -a \
+ server/readme.txt server/server.cfg server/server_linux.sh server/rcon.pl \
+ $PKG/usr/doc/$PRGNAM-$VERSION/server
+
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/games/xonotic/xonotic.info b/games/xonotic/xonotic.info
index 9479e96ae8..14b4c440ca 100644
--- a/games/xonotic/xonotic.info
+++ b/games/xonotic/xonotic.info
@@ -1,10 +1,10 @@
PRGNAM="xonotic"
-VERSION="0.8.2"
+VERSION="0.8.6"
HOMEPAGE="http://www.xonotic.org/"
-DOWNLOAD="http://dl.xonotic.org/xonotic-0.8.2.zip"
-MD5SUM="1bd46c1fb79aae42bb13e74f5a0ff46e"
+DOWNLOAD="http://dl.xonotic.org/xonotic-0.8.6.zip"
+MD5SUM="32cdf9f90930e4599177dafc41adda48"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="S. S. Bolokanar"
-EMAIL="sbolokanov@abv.bg"
+EMAIL="bolokanar@bulgarsociety.org"