summaryrefslogtreecommitdiffstats
path: root/games/rpcs3
diff options
context:
space:
mode:
Diffstat (limited to 'games/rpcs3')
-rw-r--r--games/rpcs3/README7
-rw-r--r--games/rpcs3/doinst.sh9
-rw-r--r--games/rpcs3/rpcs3.SlackBuild167
-rw-r--r--games/rpcs3/rpcs3.info34
-rw-r--r--games/rpcs3/slack-desc19
5 files changed, 236 insertions, 0 deletions
diff --git a/games/rpcs3/README b/games/rpcs3/README
new file mode 100644
index 0000000000..a2e2db0978
--- /dev/null
+++ b/games/rpcs3/README
@@ -0,0 +1,7 @@
+The world's first free and open-source PlayStation 3 emulator/debugger,
+written in C++ for Windows, Linux, macOS and FreeBSD.
+
+You can find some basic information on our website. Game info is being
+populated on the Wiki. For discussion about this emulator, PS3
+emulation, and game compatibility reports, please visit our forums and
+our Discord server.
diff --git a/games/rpcs3/doinst.sh b/games/rpcs3/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/games/rpcs3/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/rpcs3/rpcs3.SlackBuild b/games/rpcs3/rpcs3.SlackBuild
new file mode 100644
index 0000000000..4a6f4198f2
--- /dev/null
+++ b/games/rpcs3/rpcs3.SlackBuild
@@ -0,0 +1,167 @@
+#!/bin/bash
+
+# Slackware build script for rpcs3
+
+# Copyright 2022-2023 Steven Voges <Oregon, USA>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=rpcs3
+VERSION=${VERSION:-0.0.27}
+COMMITVER=${COMMITVER:-0178b20}
+COMMITNUM=${COMMITNUM:-14783}
+ASMJIT=${ASMJIT:-06d0badec53710a4f572cf5642881ce570c5d274}
+CUBEB=${CUBEB:-70b4e3db7822de4d534959885cda109d6edbee36}
+GLSLANG=${GLSLANG:-10423ec659d301a0ff2daac8bbf38980abf27590}
+HIDAPI=${HIDAPI:-ecf1b62882c1b6ca1da445fa94ee8dae42cf5961}
+ITTAPI=${ITTAPI:-3.18.12}
+LLVM=${LLVM:-9b52b6c39ae9f0759fbce7dd0db4b3290d6ebc56}
+MINIUPNP=${MINIUPNP:-f4a739d73083bee207af30b8aa3e668383ee070e}
+SOUNDTOUCH=${SOUNDTOUCH:-83cfba67b6af80bb9bfafc0b324718c4841f2991}
+SPIRVHEADERS=${SPIRVHEADERS:-85a1ed200d50660786c1a88d9166e871123cce39}
+SPIRVTOOLS=${SPIRVTOOLS:-eb0a36633d2acf4de82588504f951ad0f2cecacb}
+WOLFSSL=${WOLFSSL:-4fbd4fd36a21efd9d1a7e17aba390e91c78693b1}
+YAMLCPP=${YAMLCPP:-0b67821f307e8c6bf0eba9b6d3250e3cf1441450}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+DEPS=$TMP/$PRGNAM-$VERSION/3rdparty
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+mkdir -p $TMP/$PRGNAM-$VERSION/build/3rdparty/llvm_build/ittapi
+tar xvf $CWD/SPIRV-Headers-$SPIRVHEADERS.tar.gz -C \
+ $DEPS/SPIRV/SPIRV-Headers --strip-components 1
+tar xvf $CWD/SPIRV-Tools-$SPIRVTOOLS.tar.gz -C \
+ $DEPS/SPIRV/SPIRV-Tools --strip-components 1
+tar xvf $CWD/asmjit-$ASMJIT.tar.gz -C \
+ $DEPS/asmjit/asmjit --strip-components 1
+tar xvf $CWD/cubeb-$CUBEB.tar.gz -C \
+ $DEPS/cubeb/cubeb --strip-components 1
+tar xvf $CWD/glslang-$GLSLANG.tar.gz -C \
+ $DEPS/glslang/glslang --strip-components 1
+tar xvf $CWD/hidapi-$HIDAPI.tar.gz -C \
+ $DEPS/hidapi/hidapi --strip-components 1
+tar xvf $CWD/ittapi-$ITTAPI.tar.gz -C \
+ $TMP/$PRGNAM-$VERSION/build/3rdparty/llvm_build/ittapi --strip-components 1
+tar xvf $CWD/llvm-mirror-$LLVM.tar.gz -C \
+ $DEPS/../llvm --strip-components 1
+tar xvf $CWD/miniupnp-$MINIUPNP.tar.gz -C \
+ $DEPS/miniupnp/miniupnp --strip-components 1
+tar xvf $CWD/soundtouch-$SOUNDTOUCH.tar.gz -C \
+ $DEPS/SoundTouch/soundtouch --strip-components 1
+tar xvf $CWD/wolfssl-$WOLFSSL.tar.gz -C \
+ $DEPS/wolfssl/wolfssl --strip-components 1
+tar xvf $CWD/yaml-cpp-$YAMLCPP.tar.gz -C \
+ $DEPS/yaml-cpp/yaml-cpp --strip-components 1
+
+#Bypass git checkout check for ittapi
+sed -i 's/if(NOT GIT_CHECKOUT_RESULT EQUAL "0")/if(GIT_CHECKOUT_RESULT EQUAL "0")/g' \
+ llvm/lib/ExecutionEngine/IntelJITEvents/CMakeLists.txt
+
+#Set correct version
+sed -i "s/set(RPCS3_GIT_VERSION \"local_build\")/set(RPCS3_GIT_VERSION \"$COMMITNUM-$COMMITVER\")/g" \
+ rpcs3/git-version.cmake
+sed -i 's/set(RPCS3_GIT_BRANCH "local_build")/set(RPCS3_GIT_BRANCH "master")/g' \
+ rpcs3/git-version.cmake
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cd build
+ cmake \
+ -Wno-dev \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SYSTEM_CURL=ON \
+ -DUSE_SYSTEM_FAUDIO=ON \
+ -DUSE_SYSTEM_FFMPEG=ON \
+ -DUSE_SYSTEM_FLATBUFFERS=ON \
+ -DUSE_SYSTEM_LIBPNG=ON \
+ -DUSE_SYSTEM_LIBUSB=ON \
+ -DUSE_SYSTEM_PUGIXML=ON \
+ -DUSE_SYSTEM_XXHASH=ON \
+ -DUSE_SYSTEM_ZLIB=ON \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+rm -r $PKG/usr/share/$PRGNAM/git
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/rpcs3/rpcs3.info b/games/rpcs3/rpcs3.info
new file mode 100644
index 0000000000..d37465344c
--- /dev/null
+++ b/games/rpcs3/rpcs3.info
@@ -0,0 +1,34 @@
+PRGNAM="rpcs3"
+VERSION="0.0.27"
+HOMEPAGE="https://rpcs3.net"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://github.com/RPCS3/rpcs3/archive/v0.0.27/rpcs3-0.0.27.tar.gz \
+ https://github.com/KhronosGroup/SPIRV-Headers/archive/85a1ed200d50660786c1a88d9166e871123cce39/SPIRV-Headers-85a1ed200d50660786c1a88d9166e871123cce39.tar.gz \
+ https://github.com/KhronosGroup/SPIRV-Tools/archive/eb0a36633d2acf4de82588504f951ad0f2cecacb/SPIRV-Tools-eb0a36633d2acf4de82588504f951ad0f2cecacb.tar.gz \
+ https://github.com/RPCS3/asmjit/archive/06d0badec53710a4f572cf5642881ce570c5d274/asmjit-06d0badec53710a4f572cf5642881ce570c5d274.tar.gz \
+ https://github.com/mozilla/cubeb/archive/70b4e3db7822de4d534959885cda109d6edbee36/cubeb-70b4e3db7822de4d534959885cda109d6edbee36.tar.gz \
+ https://github.com/KhronosGroup/glslang/archive/10423ec659d301a0ff2daac8bbf38980abf27590/glslang-10423ec659d301a0ff2daac8bbf38980abf27590.tar.gz \
+ https://github.com/RPCS3/hidapi/archive/ecf1b62882c1b6ca1da445fa94ee8dae42cf5961/hidapi-ecf1b62882c1b6ca1da445fa94ee8dae42cf5961.tar.gz \
+ https://github.com/intel/ittapi/archive/v3.18.12/ittapi-3.18.12.tar.gz \
+ https://github.com/RPCS3/llvm-mirror/archive/9b52b6c39ae9f0759fbce7dd0db4b3290d6ebc56/llvm-mirror-9b52b6c39ae9f0759fbce7dd0db4b3290d6ebc56.tar.gz \
+ https://github.com/miniupnp/miniupnp/archive/f4a739d73083bee207af30b8aa3e668383ee070e/miniupnp-f4a739d73083bee207af30b8aa3e668383ee070e.tar.gz \
+ https://github.com/RPCS3/soundtouch/archive/83cfba67b6af80bb9bfafc0b324718c4841f2991/soundtouch-83cfba67b6af80bb9bfafc0b324718c4841f2991.tar.gz \
+ https://github.com/wolfSSL/wolfssl/archive/4fbd4fd36a21efd9d1a7e17aba390e91c78693b1/wolfssl-4fbd4fd36a21efd9d1a7e17aba390e91c78693b1.tar.gz \
+ https://github.com/RPCS3/yaml-cpp/archive/0b67821f307e8c6bf0eba9b6d3250e3cf1441450/yaml-cpp-0b67821f307e8c6bf0eba9b6d3250e3cf1441450.tar.gz"
+MD5SUM_x86_64="e49fa5ab11967f88471627513a6c6298 \
+ 10d5e8160f39344a641523810b075568 \
+ a4bdb8161f0e959c75d0d82d367c24f2 \
+ 26455042d0e12b9b4eff611f0767e42e \
+ f211db8fbdfd1db70e2fd517643bf88a \
+ 0af2d9f95c55adf7c670f25825eeda12 \
+ 985de60b3d3914fa73724ab123aac637 \
+ 4a5eee8a589fa777f4a6017ab1e6f602 \
+ fff968ef77c2932c340b4c0d56247679 \
+ 9dc008de95815524d6c6a04b61395ea7 \
+ a6e4341748f10956754201939b9936e4 \
+ 538eed5fafa1db75cd0b90fb5021a819 \
+ 4ff126bd4f429b86da943a77805dfec8"
+REQUIRES="FAudio flatbuffers pugixml"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/games/rpcs3/slack-desc b/games/rpcs3/slack-desc
new file mode 100644
index 0000000000..79070f7342
--- /dev/null
+++ b/games/rpcs3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rpcs3: rpcs3 (Playstation 3 Emulator)
+rpcs3:
+rpcs3: PS3 emulator/debugger
+rpcs3:
+rpcs3: Homepage: https://rpcs3.net
+rpcs3:
+rpcs3:
+rpcs3:
+rpcs3:
+rpcs3:
+rpcs3: