summaryrefslogtreecommitdiffstats
path: root/games/pysolfc
diff options
context:
space:
mode:
Diffstat (limited to 'games/pysolfc')
-rw-r--r--games/pysolfc/pysolfc.SlackBuild28
-rw-r--r--games/pysolfc/pysolfc.info10
-rw-r--r--games/pysolfc/slack-desc4
3 files changed, 28 insertions, 14 deletions
diff --git a/games/pysolfc/pysolfc.SlackBuild b/games/pysolfc/pysolfc.SlackBuild
index 684a4ce583..bc059bcad7 100644
--- a/games/pysolfc/pysolfc.SlackBuild
+++ b/games/pysolfc/pysolfc.SlackBuild
@@ -8,6 +8,13 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240824 bkw: update for v3.0.0 (and cardset-minimal 3.0.0).
+
+# 20231216 bkw: update for v2.21.0 (and cardset-minimal 2.2.0),
+# fix broken permissions for cardsets.
+
+# 20230111 bkw: update for v2.18.0 (and cardset-minimal 2.1.0).
+
# 20211228 bkw: update for v2.14.1.
# - relicensed as WTFPL with permission from Matthew.
# - we now use python3 and -current's python-pillow, no need for
@@ -32,16 +39,16 @@
# - Include all_games.html in the docdir (with fixed paths for the links).
# - Update README and slack-desc.
-SRCNAM=PySolFC
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pysolfc
-VERSION=${VERSION:-2.14.1}
+SRCNAM=PySolFC
+VERSION=${VERSION:-3.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-CARDSETVER=${CARDSETVER:-2.0}
+CARDSETVER=${CARDSETVER:-3.0.0}
CARDSETS=$SRCNAM-Cardsets--Minimal-$CARDSETVER
if [ -z "$ARCH" ]; then
@@ -63,18 +70,25 @@ OUTPUT=${OUTPUT:-/tmp}
set -e
+# 20230111 bkw: upstream starting using "pysol-x.x.x" for the tag.
+# handle either name for the tarball, because I probably want to keep
+# running the old version.
+TARBALL=$CWD/$SRCNAM-$PRGNAM-$VERSION.tar.gz
+[ -e $TARBALL ] || TARBALL=$CWD/$SRCNAM-$VERSION.tar.gz
+TARDIR=$( basename $TARBALL .tar.gz )
+
fixperms() {
chown -R root:root $1
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ find -L $1 -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
}
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
-cd $SRCNAM-$VERSION
+rm -rf $TARDIR
+tar xvf $TARBALL
+cd $TARDIR
fixperms .
# do not use 'make install', it has no way to pass --root to setup.py.
diff --git a/games/pysolfc/pysolfc.info b/games/pysolfc/pysolfc.info
index 2185279748..6750c1fccc 100644
--- a/games/pysolfc/pysolfc.info
+++ b/games/pysolfc/pysolfc.info
@@ -1,10 +1,10 @@
PRGNAM="pysolfc"
-VERSION="2.14.1"
+VERSION="3.0.0"
HOMEPAGE="https://pysolfc.sourceforge.io"
-DOWNLOAD="https://github.com/shlomif/PySolFC/archive/2.14.1/PySolFC-2.14.1.tar.gz \
- https://downloads.sourceforge.net/pysolfc/PySolFC-Cardsets--Minimal-2.0.tar.xz"
-MD5SUM="c833407fc80c6f175d16616ba1533610 \
- 85c0edeeb0e319d54f9ebcd4165a2077"
+DOWNLOAD="https://github.com/shlomif/PySolFC/archive/pysolfc-3.0.0/PySolFC-pysolfc-3.0.0.tar.gz \
+ https://downloads.sourceforge.net/project/pysolfc/PySolFC-Cardsets/minimal/PySolFC-Cardsets--Minimal-3.0.0.tar.xz"
+MD5SUM="e32032fa681d6d0fb27cb28bb8c37238 \
+ 0bdd0de61bfe5a97ad9eb10516f7356a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="configobj python3-attrs"
diff --git a/games/pysolfc/slack-desc b/games/pysolfc/slack-desc
index 35b9a4caa7..bb9d560a11 100644
--- a/games/pysolfc/slack-desc
+++ b/games/pysolfc/slack-desc
@@ -8,8 +8,8 @@
|-----handy-ruler------------------------------------------------------|
pysolfc: pysolfc (solitaire card game suite)
pysolfc:
-pysolfc: PySolFC is a colection of more than 1000 solitaire card games. It is
-pysolfc: a fork of the no longer maintained PySol Solitaire. There are games
+pysolfc: PySolFC is a collection of more than 1200 solitaire card games. It is
+pysolfc: a fork of the no-longer-maintained PySol Solitaire. There are games
pysolfc: that use the 52 card International Pattern deck, games for the 78 card
pysolfc: Tarock deck, eight and ten suite Ganjifa games, Hanafuda games, Matrix
pysolfc: games, Mahjongg games, and games for an original hexadecimal-based