summaryrefslogtreecommitdiffstats
path: root/games/ppsspp/ppsspp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/ppsspp/ppsspp.SlackBuild')
-rw-r--r--games/ppsspp/ppsspp.SlackBuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/games/ppsspp/ppsspp.SlackBuild b/games/ppsspp/ppsspp.SlackBuild
index d637dbcef6..3a4765e2dc 100644
--- a/games/ppsspp/ppsspp.SlackBuild
+++ b/games/ppsspp/ppsspp.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ppsspp
+VERSION=${VERSION:-2016.10.26_cc37528}
SRCNAM=$(echo $PRGNAM | tr [a-z] [A-Z])
-VERSION=${VERSION:-2016.07.25_fa3f219}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,8 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Upstream apparently utterly clueless about how to invoke ccache
-patch -p1 < $CWD/ppsspp-no-ccache.patch
+# cmake 3.6 is required.
+# https://github.com/hrydgard/ppsspp/issues/9087
+sed -i 's/VERSION 3.6/VERSION 3.5.2/' CMakeLists.txt
mkdir -p build
cd build
@@ -79,24 +80,29 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_SKIP_RPATH=TRUE \
- -DUSE_SYSTEM_FFMPEG=ON \
-Wno-dev \
-DCMAKE_BUILD_TYPE=Release ..
make
# No install target
- mkdir -p $PKG/usr/share/{applications,icons/hicolor,$PRGNAM}
install -Dm0755 ${SRCNAM}SDL $PKG/usr/games/$PRGNAM
- install -Dm0644 ../assets/unix-icons/icon-512.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
+ mkdir -p $PKG/usr/share/$PRGNAM
cp -a assets $PKG/usr/share/$PRGNAM
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-cp -a assets/unix-icons/hicolor/* $PKG/usr/share/icons/hicolor/
+# Install hicolor
+for dir in icons/hicolor/* ; do
+ if [ -f $dir/apps/$PRGNAM.png ]; then
+ install -Dm0644 $dir/apps/$PRGNAM.png $PKG/usr/share/$dir/apps/$PRGNAM.png
+ fi
+done
+install -Dm0644 icons/icon-512.svg $PKG/usr/share/pixmaps/$PRGNAM.svg
# Write a desktop file
+mkdir -p $PKG/usr/share/applications
cat > $PKG/usr/share/applications/$PRGNAM.desktop <<EOF
[Desktop Entry]
Name=$SRCNAM
@@ -116,4 +122,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}