summaryrefslogtreecommitdiffstats
path: root/games/pgn-extract/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/pgn-extract/Makefile.patch')
-rw-r--r--games/pgn-extract/Makefile.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/games/pgn-extract/Makefile.patch b/games/pgn-extract/Makefile.patch
new file mode 100644
index 0000000000..9a4fde63a2
--- /dev/null
+++ b/games/pgn-extract/Makefile.patch
@@ -0,0 +1,18 @@
+--- Makefile 2022-01-26 00:21:45.000000000 +0200
++++ Makefile.new 2024-01-11 03:29:04.935018734 +0200
+@@ -35,14 +35,11 @@
+ # Mac OS X users might need to add -D__unix__ to CFLAGS
+ # and use CC=cc or CC=gcc
+
+-OPTIMISE=-O3
+-
+ CFLAGS+=-c -pedantic -Wall -Wshadow -Wformat -Wpointer-arith \
+ -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings \
+ -Wsign-compare -Wimplicit-function-declaration $(DEBUGINFO) \
+ -I/usr/local/lib/ansi-include -std=c99 \
+- $(CPPFLAGS) \
+- $(OPTIMISE)
++ $(CPPFLAGS)
+
+ CC=gcc
+ LIBS=-lm