summaryrefslogtreecommitdiffstats
path: root/games/openmsx/openmsx.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/openmsx/openmsx.SlackBuild')
-rw-r--r--games/openmsx/openmsx.SlackBuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/games/openmsx/openmsx.SlackBuild b/games/openmsx/openmsx.SlackBuild
index 85380f5650..5297add896 100644
--- a/games/openmsx/openmsx.SlackBuild
+++ b/games/openmsx/openmsx.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for OpenMSX
# Copyright 2013-2014 Erwin van Zanten, Dordrecht, The Netherlands
+# Copyright 2015 Philip van der Hoeven, Almere, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=openmsx
-VERSION=${VERSION:-0.10.1}
+VERSION=${VERSION:-0.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,16 +70,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix-dir=/usr \
- --binary-dir=/games \
- --data-dir=/share/games/openmsx \
- --icon-dir=/share/pixmaps \
- --doc-dir=/doc/$PRGNAM-$VERSION \
- --personal-dir=.openmsx \
- --install-dir=$PKG
+sed -i 's@SYMLINK_FOR_BINARY:=true@SYMLINK_FOR_BINARY:=false@' build/custom.mk
+sed -i 's@INSTALL_BASE:=/opt/openMSX@INSTALL_BASE:=/usr/share/openmsx@' build/custom.mk
+echo "INSTALL_DOC_DIR:=/usr/doc/openmsx-$VERSION" >> build/custom.mk
+echo "INSTALL_SHARE_DIR:=/usr/share/openmsx" >> build/custom.mk
+echo "INSTALL_BINARY_DIR:=/usr/bin" >> build/custom.mk
+
+./configure
make
make install DESTDIR=$PKG
@@ -87,9 +85,14 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/usr/share/applications
+cat $CWD/openmsx.desktop > $PKG/usr/share/applications/openmsx.desktop
+install -m 0644 -D $PKG/usr/share/openmsx/icons/openMSX-logo-48.png \
+ $PKG/usr/share/pixmaps/openmsx.png
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh