summaryrefslogtreecommitdiffstats
path: root/games/oolite/oolite.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/oolite/oolite.SlackBuild')
-rw-r--r--games/oolite/oolite.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/games/oolite/oolite.SlackBuild b/games/oolite/oolite.SlackBuild
index e93dc5ce54..9b44ab48a8 100644
--- a/games/oolite/oolite.SlackBuild
+++ b/games/oolite/oolite.SlackBuild
@@ -22,6 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Modified by the SlackBuilds.org project.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=oolite
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -84,12 +83,11 @@ rm deps/Linux-deps/x86*/lib/*
source /usr/share/GNUstep/Makefiles/GNUstep.sh
export GNUSTEP_MAKEFILES=/usr/share/GNUstep/Makefiles
-## Link to espeak-ng instead of espeak
-# -e "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" \
sed -i \
-e "/ADDITIONAL_OBJCFLAGS/s/=/= -fobjc-exceptions ${SLKCFLAGS}/" \
-e "s/-mtune=generic//g" \
-e "s/ -lpng / -l:libpng14.so.14 /g" \
+ -e "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" \
GNUmakefile
make -f Makefile ESPEAK=yes use_deps=no debug=no release