summaryrefslogtreecommitdiffstats
path: root/games/oblige-legacy4/oblige-legacy4.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/oblige-legacy4/oblige-legacy4.SlackBuild')
-rw-r--r--games/oblige-legacy4/oblige-legacy4.SlackBuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/games/oblige-legacy4/oblige-legacy4.SlackBuild b/games/oblige-legacy4/oblige-legacy4.SlackBuild
new file mode 100644
index 0000000000..537ec4a899
--- /dev/null
+++ b/games/oblige-legacy4/oblige-legacy4.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/sh
+
+# Slackware build script for oblige-legacy4
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20140827 bkw:
+# - rename this build to oblige-legacy4 so we can update oblige to v6.
+# keep both around for now, as v6 lacks heretic/quake support.
+
+# 20140213 bkw: bump BUILD to 2.
+# Makefile.unixy updated so it installs data/doom[12]_boss (thanks to Black
+# Rider for the bug report). Also get rid of +x permissions on the data files
+# in /usr/share.
+
+PRGNAM=oblige-legacy4
+VERSION=${VERSION:-4.28b}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+OLDNAM="oblige"
+SRCVER=${VERSION//./}
+SRCNAM="Oblige" # grrrr!
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/usr/bin $PKG/usr/share/$PRGNAM $OUTPUT
+cd $TMP
+rm -rf ${SRCNAM}-${VERSION}-source
+unzip $CWD/$OLDNAM-$SRCVER-source.zip
+cd ${SRCNAM}-${VERSION}-source
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Makefile.unixy originally came from the oblige author, I've hacked
+# it up to make it work with oblige 4.x and SBo's fltk13.
+cp $CWD/Makefile.unixy Makefile
+
+# Fix a missing include
+sed -i '1i#include <unistd.h>' gui/lib_util.cc
+
+# Legacy version shouldn't use same /usr/share and dotfile dir as
+# current version.
+sed -i "s,\.$OLDNAM,.$PRGNAM,g" doc/File_Layout.txt gui/main.cc
+sed -i "s,share/$OLDNAM,share/$PRGNAM," gui/main.cc
+
+make INSTALL_PREFIX=/usr OPTIMISE="$SLKCFLAGS" FLTK_CONFIG=fltk13-config
+make install INSTALL_PREFIX=$PKG/usr
+
+mkdir -p $PKG/usr/share/pixmaps $PKG/usr/share/applications
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp *.txt doc/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}