summaryrefslogtreecommitdiffstats
path: root/games/noteye/noteye.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/noteye/noteye.SlackBuild')
-rw-r--r--games/noteye/noteye.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/noteye/noteye.SlackBuild b/games/noteye/noteye.SlackBuild
index 828e65f220..4ae54029b8 100644
--- a/games/noteye/noteye.SlackBuild
+++ b/games/noteye/noteye.SlackBuild
@@ -74,6 +74,9 @@ sed -i 's,-llua5.1,-llua,g' src/Makefile
# store the writable high score file in /var, not /usr/share.
sed -i 's,"hydrascores.sav","/var/games/hydrascores.sav",' hydra/hydra.cpp
+# use clang++ as the code won't build with gcc >= 5.x
+sed -i 's|g++ |clang++ |' src/Makefile
+
make -C src CFLAGS="$SLKCFLAGS"
# The 'make install' target is bad and wrong. Don't use.