summaryrefslogtreecommitdiffstats
path: root/games/mrboom/mrboom.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/mrboom/mrboom.SlackBuild')
-rw-r--r--games/mrboom/mrboom.SlackBuild50
1 files changed, 17 insertions, 33 deletions
diff --git a/games/mrboom/mrboom.SlackBuild b/games/mrboom/mrboom.SlackBuild
index 82f113fc0d..3b4d4f1c46 100644
--- a/games/mrboom/mrboom.SlackBuild
+++ b/games/mrboom/mrboom.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mrboom
-# Copyright 2017-2020 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2017-2023 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,20 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 20220222 bkw: Modified by SlackBuilds.org:
-# - fix build on 15.0.
-# - actually use SLKCFLAGS.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mrboom
-VERSION=${VERSION:-4.9}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-5.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=mrboom-libretro
-LIBNAM=mrboom_libretro
+SRCNAM=MrBoom-src
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -63,6 +58,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -83,38 +81,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-patch -p0 < $CWD/Makefile.patch
sed -i "s,-O3,$SLKCFLAGS -fcommon," Makefile
-sed -i "s|^GIT_VERSION :=.*|GIT_VERSION := \" ${VERSION}\"|" Makefile
-
-if pkg-config --exists sdl2; then
- make mrboom LIBSDL2=1
-
- mkdir -p $PKG/usr/games $PKG/usr/man/man6 $PKG/usr/share/applications $PKG/usr/share/pixmaps
-
- make install PREFIX=/usr BINDIR=games DESTDIR=$PKG
+make mrboom LIBSDL2=1
+make install PREFIX=/usr BINDIR=games DESTDIR=$PKG
- install -m 0644 Assets/$PRGNAM.desktop $PKG/usr/share/applications
- install -m 0644 $CWD/mrboom.svg $PKG/usr/share/pixmaps
+install -D -m 644 Assets/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+install -D -m 644 $CWD/mrboom.svg $PKG/usr/share/pixmaps/mrboom.svg
- for i in 16x16 32x32 48x48 256x256; do
- install -D -m0644 Assets/hicolor/$i/apps/$PRGNAM.png $PKG/usr/share/icons/hicolor/$i/apps/$PRGNAM.png
- done
-
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-fi
-
-make clean
-make
-
-install -D -m 0644 $LIBNAM.so $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
-install -D -m 0644 $CWD/$LIBNAM.info $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info
+for i in 16x16 32x32 48x48 256x256; do
+ install -D -m 644 Assets/hicolor/$i/apps/$PRGNAM.png $PKG/usr/share/icons/hicolor/$i/apps/$PRGNAM.png
+done
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
LICENSE README.md \