summaryrefslogtreecommitdiffstats
path: root/games/maelstrom/maelstrom.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/maelstrom/maelstrom.SlackBuild')
-rw-r--r--games/maelstrom/maelstrom.SlackBuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/games/maelstrom/maelstrom.SlackBuild b/games/maelstrom/maelstrom.SlackBuild
index cd31964dfa..18bd8ae4f7 100644
--- a/games/maelstrom/maelstrom.SlackBuild
+++ b/games/maelstrom/maelstrom.SlackBuild
@@ -6,21 +6,20 @@
# Note to 64-bit users: Maelstrom-netd and the -server option to Maelstrom
# do not work correctly. I haven't investigated why. You can still play
-# networked games in non-server mode (see man page). Users of actual
+# networked games in non-server mode (see man page). Users of 32-bit
# Slackware are not affected by this.
PRGNAM=maelstrom
-SRCNAM=Maelstrom
VERSION=${VERSION:-3.0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
+SRCNAM=Maelstrom
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -72,35 +71,30 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-strip $PKG/usr/games/*
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-make install_gamedocs target=$PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Why does `make install' install this?
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Docs/Makefile
-
-install -m0755 -o root -g root $CWD/maelstrom_addon_package.pl $PKG/usr/games
+strip --strip-unneeded $PKG/usr/games/*
# CLI users would probably prefer to type 'maelstrom', not 'Maelstrom'
( cd $PKG/usr/games && ln -s $SRCNAM $PRGNAM )
-mkdir -p $PKG/usr/share/pixmaps
-( cd $PKG/usr/share/pixmaps
- ln -s ../games/$SRCNAM/icon.xpm $PRGNAM.xpm
-)
+install -m0755 -o root -g root $CWD/maelstrom_addon_package.pl $PKG/usr/games
mkdir -p $PKG/usr/share/applications
cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+mkdir -p $PKG/usr/share/pixmaps
+( cd $PKG/usr/share/pixmaps ; ln -s ../games/$SRCNAM/icon.xpm $PRGNAM.xpm )
+
mkdir -p $PKG/usr/man/man6
gzip -9c $CWD/$SRCNAM.6 > $PKG/usr/man/man6/$SRCNAM.6.gz
-
( cd $PKG/usr/man/man6
ln -s $SRCNAM.6.gz $PRGNAM.6.gz
- ln -s $SRCNAM.6.gz $SRCNAM-netd.6.gz
-)
+ ln -s $SRCNAM.6.gz $SRCNAM-netd.6.gz )
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+make install_gamedocs target=$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Why does `make install' install this?
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Docs/Makefile
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc