summaryrefslogtreecommitdiffstats
path: root/games/jfsw/patches/jfbuild_src_20051009.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/jfsw/patches/jfbuild_src_20051009.patch')
-rw-r--r--games/jfsw/patches/jfbuild_src_20051009.patch48
1 files changed, 24 insertions, 24 deletions
diff --git a/games/jfsw/patches/jfbuild_src_20051009.patch b/games/jfsw/patches/jfbuild_src_20051009.patch
index 653013043a..5cf0cb2feb 100644
--- a/games/jfsw/patches/jfbuild_src_20051009.patch
+++ b/games/jfsw/patches/jfbuild_src_20051009.patch
@@ -2,14 +2,14 @@ diff -Nur jfbuild_src_20051009.orig/include/editor.h jfbuild_src_20051009/includ
--- jfbuild_src_20051009.orig/include/editor.h 2005-10-09 15:23:02.000000000 +0200
+++ jfbuild_src_20051009/include/editor.h 2005-10-10 15:06:18.000000000 +0200
@@ -18,7 +18,7 @@
-
- extern short temppicnum, tempcstat, templotag, temphitag, tempextra;
- extern char tempshade, temppal, tempxrepeat, tempyrepeat;
--extern char somethingintab;
-+static char somethingintab;
-
- extern char buildkeys[NUMBUILDKEYS];
-
+
+ extern short temppicnum, tempcstat, templotag, temphitag, tempextra;
+ extern char tempshade, temppal, tempxrepeat, tempyrepeat;
+-extern char somethingintab;
++static char somethingintab;
+
+ extern char buildkeys[NUMBUILDKEYS];
+
diff -Nur jfbuild_src_20051009.orig/Makefile jfbuild_src_20051009/Makefile
--- jfbuild_src_20051009.orig/Makefile 2005-10-09 15:23:00.000000000 +0200
+++ jfbuild_src_20051009/Makefile 2005-10-10 15:06:22.000000000 +0200
@@ -38,22 +38,22 @@ diff -Nur jfbuild_src_20051009.orig/src/crc32.c jfbuild_src_20051009/src/crc32.c
--- jfbuild_src_20051009.orig/src/crc32.c 2005-10-09 15:23:00.000000000 +0200
+++ jfbuild_src_20051009/src/crc32.c 2005-10-10 15:06:18.000000000 +0200
@@ -73,16 +73,6 @@
- }
- }
-
--
--unsigned long crc32(unsigned char *blk, unsigned long len)
--{
-- unsigned long crc;
--
-- crc32init(&crc);
-- crc32block(&crc, blk, len);
-- return crc32finish(&crc);
--}
--
- void crc32init(unsigned long *crcvar)
- {
- if (!crcvar) return;
+ }
+ }
+
+-
+-unsigned long crc32(unsigned char *blk, unsigned long len)
+-{
+- unsigned long crc;
+-
+- crc32init(&crc);
+- crc32block(&crc, blk, len);
+- return crc32finish(&crc);
+-}
+-
+ void crc32init(unsigned long *crcvar)
+ {
+ if (!crcvar) return;
diff -Nur jfbuild_src_20051009.orig/src/sdlayer.c jfbuild_src_20051009/src/sdlayer.c
--- jfbuild_src_20051009.orig/src/sdlayer.c 2005-10-09 15:23:00.000000000 +0200
+++ jfbuild_src_20051009/src/sdlayer.c 2005-10-10 15:06:22.000000000 +0200