summaryrefslogtreecommitdiffstats
path: root/games/ffgo/ffgo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/ffgo/ffgo.SlackBuild')
-rw-r--r--games/ffgo/ffgo.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/games/ffgo/ffgo.SlackBuild b/games/ffgo/ffgo.SlackBuild
index 9e19a94562..c6de50dbd5 100644
--- a/games/ffgo/ffgo.SlackBuild
+++ b/games/ffgo/ffgo.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ffgo
-# Copyright 2017 Philip Lacroix <slackph at posteo dot de>
+# Copyright 2017-2023 Philip Lacroix <slackph at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,9 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ffgo
SRCNAM=FFGo
-VERSION=${VERSION:-1.12.3}
-BUILD=${BUILD:-2}
+TARNAM=python3-${SRCNAM}
+VERSION=${VERSION:-1.12.7}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,16 +40,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "x86_64" ]; then
@@ -63,7 +61,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-tar xvzf $CWD/$SRCNAM-$VERSION.tar.gz
+tar xvzf $CWD/$TARNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
@@ -78,7 +76,7 @@ python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Grab Python 3 version.
+# See Python 3 version.
PY3VER=$(python3 --version | sed -e "s~.*\(3\.[0-9]*\).*~\1~")
PRGETC=$PKG/etc/$PRGNAM