summaryrefslogtreecommitdiffstats
path: root/games/clonekeen/clonekeen.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/clonekeen/clonekeen.SlackBuild')
-rw-r--r--games/clonekeen/clonekeen.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/clonekeen/clonekeen.SlackBuild b/games/clonekeen/clonekeen.SlackBuild
index ac178a730b..b41aa20638 100644
--- a/games/clonekeen/clonekeen.SlackBuild
+++ b/games/clonekeen/clonekeen.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=clonekeen
VERSION=${VERSION:-8.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -49,6 +49,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix underlinking
+sed -i "s|-lstdc++|-lstdc++ -lm|" src/Makefile
+
# Makefile doesn't use CFLAGS, ugh
sed -i "/gcc/s/-O2/$SLKCFLAGS/" src/Makefile