summaryrefslogtreecommitdiffstats
path: root/games/bsnes/bsnes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/bsnes/bsnes.SlackBuild')
-rw-r--r--games/bsnes/bsnes.SlackBuild31
1 files changed, 10 insertions, 21 deletions
diff --git a/games/bsnes/bsnes.SlackBuild b/games/bsnes/bsnes.SlackBuild
index 3c5bc2d16d..22a62f5306 100644
--- a/games/bsnes/bsnes.SlackBuild
+++ b/games/bsnes/bsnes.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=bsnes
-VERSION=${VERSION:-0.080}
+VERSION=${VERSION:-0.082}
SRCVER=${VERSION:2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,14 +53,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch makefile so SLKCFLAGS are recognized and give option to choose
-# Qt4 or Gtk interface.
-patch -p1 < $CWD/bsnes-0.076-toolkit.patch
+# Patch makefile so SLKCFLAGS are recognized.
patch -p1 < $CWD/bsnes-0.077-makefile.patch
-# Fix snespurify scripts.
-sed -i 's|g++-4.5|g++|g' snespurify/cc-{gtk,qt}.sh
-
cd $PRGNAM
# Remove pulseaudio as there is no package for it at SBo.
@@ -71,15 +66,14 @@ sed -i \
-e '/pulse/d' ui{,-gameboy}/Makefile
# Choose whether qt or gtk interface is used. Qt4 is default.
-INTERFACE=${INTERFACE:-QT4}
-if ! [ "$INTERFACE" == 'QT4' ]; then
- TOOLKIT='gtk'
+if [ "${INTERFACE:-QT4}" != 'QT4' ]; then
+ PHOENIX='gtk'
else
- TOOLKIT='qt'
+ PHOENIX='qt'
fi
# Determine which mode to build bsnes.
-# Possible values for PROFILE are accuracy, compatibility, and performance.
+# Possible values for PROFILE: accuracy, compatibility, and performance.
PROFILE=${PROFILE:-compatibility}
CXXFLAGS="$SLKCFLAGS" \
@@ -87,7 +81,7 @@ make \
platform=x \
compiler=gcc \
prefix=/usr \
- toolkit="$TOOLKIT" \
+ phoenix="$PHOENIX" \
profile="$PROFILE"
make install DESTDIR=$PKG prefix=/usr
@@ -96,14 +90,9 @@ cd ..
# Compile snespurify. It helps clean up ROMS for use with bsnes.
cd snespurify
# Fix snespurify scripts.
-sed -i -e 's|g++-4.5|g++|g' -e "s|-O3|$SLKCFLAGS|" cc-{gtk,qt}.sh
-if [ "$INTERFACE" == "QT4" ]; then
- ./cc-qt.sh
- install -m 0755 snespurify-qt $PKG/usr/bin
-else
- ./cc-gtk.sh
- install -m 0755 snespurify-gtk $PKG/usr/bin
-fi
+sed -i -e 's|g++-4.5|g++|g' -e "s|-O3|$SLKCFLAGS|" cc-${PHOENIX}.sh
+./cc-${PHOENIX}.sh
+install -m 0755 snespurify-$PHOENIX $PKG/usr/bin
cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \