summaryrefslogtreecommitdiffstats
path: root/games/SimGear/SimGear.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/SimGear/SimGear.SlackBuild')
-rw-r--r--games/SimGear/SimGear.SlackBuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/games/SimGear/SimGear.SlackBuild b/games/SimGear/SimGear.SlackBuild
index a15494cdee..c69b40a86c 100644
--- a/games/SimGear/SimGear.SlackBuild
+++ b/games/SimGear/SimGear.SlackBuild
@@ -70,6 +70,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/0004-fix-for-boost-1.69.patch
+
mkdir -p build
cd build
cmake \
@@ -80,6 +82,11 @@ cd build
-DSYSTEM_EXPAT=ON \
-DENABLE_TESTS=OFF \
-DCMAKE_BUILD_TYPE=Release ..
+
+ # various CMakeLists.txt files must be revised for the newer cmake...
+ mv config.h ../3rdparty/udns/
+ mv simgear/simgear_config.h simgear/version.h ../simgear/
+
make
make install DESTDIR=$PKG
cd ..