summaryrefslogtreecommitdiffstats
path: root/development/zope.interface/zope.interface.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/zope.interface/zope.interface.SlackBuild')
-rw-r--r--development/zope.interface/zope.interface.SlackBuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/development/zope.interface/zope.interface.SlackBuild b/development/zope.interface/zope.interface.SlackBuild
index 5df05221c1..901493c9f0 100644
--- a/development/zope.interface/zope.interface.SlackBuild
+++ b/development/zope.interface/zope.interface.SlackBuild
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zope.interface
-VERSION=${VERSION:-5.4.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-6.3}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -57,21 +57,16 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true