summaryrefslogtreecommitdiffstats
path: root/development/spyder/spyder.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/spyder/spyder.SlackBuild')
-rw-r--r--development/spyder/spyder.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/development/spyder/spyder.SlackBuild b/development/spyder/spyder.SlackBuild
index 99f5cf5b69..bef00bb9f2 100644
--- a/development/spyder/spyder.SlackBuild
+++ b/development/spyder/spyder.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for spyder
-# Copyright 2010-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2010-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=spyder
-VERSION=${VERSION:-2.3.5.2}
+VERSION=${VERSION:-2.3.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,7 +73,9 @@ find -L . \
# change doc/conf.py to Unix format. Simple hack! :/
for FILE in $(find . -type f \( ! -iname "*\.*o" ! -iname "*\.png" \) \
| xargs grep -Pl '\r$'); do
- sed -i 's/\r//g' $FILE
+ sed -e 's/\r//g' $FILE > ${FILE}.new
+ touch -r $FILE ${FILE}.new
+ mv ${FILE}.new $FILE
done
python setup.py install --root=$PKG