summaryrefslogtreecommitdiffstats
path: root/development/qt-creator-llvm/patches/130_QTCREATORBUG-15157_Link-with-clazy_clang.patch
diff options
context:
space:
mode:
Diffstat (limited to 'development/qt-creator-llvm/patches/130_QTCREATORBUG-15157_Link-with-clazy_clang.patch')
-rw-r--r--development/qt-creator-llvm/patches/130_QTCREATORBUG-15157_Link-with-clazy_clang.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/development/qt-creator-llvm/patches/130_QTCREATORBUG-15157_Link-with-clazy_clang.patch b/development/qt-creator-llvm/patches/130_QTCREATORBUG-15157_Link-with-clazy_clang.patch
new file mode 100644
index 0000000000..60acd6d9fa
--- /dev/null
+++ b/development/qt-creator-llvm/patches/130_QTCREATORBUG-15157_Link-with-clazy_clang.patch
@@ -0,0 +1,25 @@
+diff --git a/tools/clang/tools/libclang/CIndex.cpp b/tools/clang/tools/libclang/CIndex.cpp
+index 66b6edc8b1..281ab77c23 100644
+--- a/tools/clang/tools/libclang/CIndex.cpp
++++ b/tools/clang/tools/libclang/CIndex.cpp
+@@ -8479,4 +8479,8 @@ static int LLVM_ATTRIBUTE_UNUSED ClangTidyPluginAnchorDestination =
+ extern volatile int ClangIncludeFixerPluginAnchorSource;
+ static int LLVM_ATTRIBUTE_UNUSED ClangIncludeFixerPluginAnchorDestination =
+ ClangIncludeFixerPluginAnchorSource;
++
++// This anchor is used to force the linker to link the clazy plugin.
++extern volatile int ClazyPluginAnchorSource;
++static int LLVM_ATTRIBUTE_UNUSED ClazyPluginAnchorDestination = ClazyPluginAnchorSource;
+ #endif
+diff --git a/tools/clang/tools/libclang/CMakeLists.txt b/tools/clang/tools/libclang/CMakeLists.txt
+index 4440637820..6798d2ee8b 100644
+--- a/tools/clang/tools/libclang/CMakeLists.txt
++++ b/tools/clang/tools/libclang/CMakeLists.txt
+@@ -51,6 +51,7 @@ if (TARGET clangTidyPlugin)
+ add_definitions(-DCLANG_TOOL_EXTRA_BUILD)
+ list(APPEND LIBS clangTidyPlugin)
+ list(APPEND LIBS clangIncludeFixerPlugin)
++ list(APPEND LIBS clazyPlugin)
+ endif ()
+
+ find_library(DL_LIBRARY_PATH dl)