summaryrefslogtreecommitdiffstats
path: root/development/nose/nose.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/nose/nose.SlackBuild')
-rw-r--r--development/nose/nose.SlackBuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/development/nose/nose.SlackBuild b/development/nose/nose.SlackBuild
index d5d4a8b704..ca69c05d72 100644
--- a/development/nose/nose.SlackBuild
+++ b/development/nose/nose.SlackBuild
@@ -2,20 +2,18 @@
# Slackware build script for nose
-# Written by Mikko Varri (vmj@linuxbox.fi)
+# Written by Mikko Värri (vmj@linuxbox.fi)
# Public domain
PRGNAM=nose
-VERSION=${VERSION:-0.11.1}
+VERSION=${VERSION:-0.11.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -41,17 +39,15 @@ find . \
-exec chmod 644 {} \;
python setup.py install --root=$PKG
+make -C doc html || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGELOG NEWS PKG-INFO README.txt lgpl.txt \
+cp -a AUTHORS CHANGELOG NEWS PKG-INFO README.txt lgpl.txt examples \
$PKG/usr/doc/$PRGNAM-$VERSION
-cp -a examples $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a doc $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a doc/.build/html $PKG/usr/doc/$PRGNAM-$VERSION || cp -a doc $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install