summaryrefslogtreecommitdiffstats
path: root/development/mrustc/mrustc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/mrustc/mrustc.SlackBuild')
-rw-r--r--development/mrustc/mrustc.SlackBuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/development/mrustc/mrustc.SlackBuild b/development/mrustc/mrustc.SlackBuild
index 1f1a64d468..909bcb38ae 100644
--- a/development/mrustc/mrustc.SlackBuild
+++ b/development/mrustc/mrustc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mrustc
-# Copyright 2017-2018 Andrew Clemons, Wellington New Zealand
+# Copyright 2017-2019 Andrew Clemons, Wellington New Zealand
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mrustc
-GITREV=${GITREV:-346da1865a49d7fd354e7aa4e8b5712a2df35a22}
-VERSION=${VERSION:-git$(echo "$GITREV" | sed 's/^\(.\{7\}\).*$/\1/')}
+VERSION=${VERSION:-0.8.0}
RUSTCVERSION=${RUSTCVERSION:-1.19.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -76,14 +75,16 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$GITREV
-tar xvf $CWD/$PRGNAM-$GITREV.tar.gz
-cd $PRGNAM-$GITREV
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
-cp $CWD/rustc-$RUSTCVERSION-src.tar.xz .
+patch -p1 < "$CWD/mrustc-0.8.0-fix-variable-length-integer-receiving.patch"
sed -i '/curl -sS https:/d' Makefile
sed -i 's/-src.tar.gz/-src.tar.xz/' Makefile
+cp "$CWD/rustc-$RUSTCVERSION-src.tar.xz" .
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -93,16 +94,9 @@ find -L . \
make RUSTCSRC
-LLVM_TARGETS="X86"
-
-if [ "$ARCH" = "arm" ] ; then
- LLVM_TARGETS="$LLVM_TARGETS;ARM"
-fi
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
RUSTC_TARGET="$RUSTC_TARGET" \
-LLVM_TARGETS="$LLVM_TARGETS" \
CC=gcc \
make -f minicargo.mk
@@ -112,7 +106,6 @@ if [ "$WITH_RUSTC" = "yes" ] ; then
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
RUSTC_TARGET="$RUSTC_TARGET" \
- LLVM_TARGETS="$LLVM_TARGETS" \
CC=gcc \
make -j1 -C run_rustc
fi