summaryrefslogtreecommitdiffstats
path: root/development/jupyterlab_server/jupyterlab_server.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyterlab_server/jupyterlab_server.SlackBuild')
-rw-r--r--development/jupyterlab_server/jupyterlab_server.SlackBuild30
1 files changed, 5 insertions, 25 deletions
diff --git a/development/jupyterlab_server/jupyterlab_server.SlackBuild b/development/jupyterlab_server/jupyterlab_server.SlackBuild
index 168df6f102..a5a7de3c48 100644
--- a/development/jupyterlab_server/jupyterlab_server.SlackBuild
+++ b/development/jupyterlab_server/jupyterlab_server.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyterlab_server
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyterlab_server
-VERSION=${VERSION:-2.14.0}
+VERSION=${VERSION:-2.16.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,31 +76,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from distutils.core import setup
-import os
-here = os.path.abspath(os.path.dirname(__file__))
-pjoin = os.path.join
-packages = []
-for d, _, _ in os.walk(pjoin(here, 'jupyterlab_server')):
- packages.append(d[len(here)+1:].replace(os.path.sep, '.'))
-setup(name='${PRGNAM}',
- version='${VERSION}',
- packages=packages,
- package_data={'': ['*']},
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.md README.md RELEASE.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install