summaryrefslogtreecommitdiffstats
path: root/development/jupyterlab
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyterlab')
-rw-r--r--development/jupyterlab/README3
-rw-r--r--development/jupyterlab/doinst.sh9
-rw-r--r--development/jupyterlab/jupyterlab.SlackBuild27
-rw-r--r--development/jupyterlab/jupyterlab.desktop11
-rw-r--r--development/jupyterlab/jupyterlab.info8
5 files changed, 34 insertions, 24 deletions
diff --git a/development/jupyterlab/README b/development/jupyterlab/README
index f8918f06b1..187b0fea52 100644
--- a/development/jupyterlab/README
+++ b/development/jupyterlab/README
@@ -7,3 +7,6 @@ JupyterLab will eventually replace the classic Jupyter Notebook.
Jupyter kernels are needed for JupyterLab to be fully functional. The
following kernels are currently available as SlackBuilds:
* jupyter-ipykernel
+
+jupyterlab 3.5.3 is the last possible version for Slackware 15.0.
+Newer versions would require a newer jupyterlab_server.
diff --git a/development/jupyterlab/doinst.sh b/development/jupyterlab/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/development/jupyterlab/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/development/jupyterlab/jupyterlab.SlackBuild b/development/jupyterlab/jupyterlab.SlackBuild
index a03f9d0f01..ff99229931 100644
--- a/development/jupyterlab/jupyterlab.SlackBuild
+++ b/development/jupyterlab/jupyterlab.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyterlab
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyterlab
-VERSION=${VERSION:-3.5.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-3.5.3}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -91,6 +74,9 @@ sed 's|etc|/etc|' -i setup.py
python3 setup.py install --root=$PKG
+# Install desktop file
+install -Dm644 $CWD/jupyterlab.desktop $PKG/usr/share/applications/jupyterlab.desktop
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -100,6 +86,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyterlab/jupyterlab.desktop b/development/jupyterlab/jupyterlab.desktop
new file mode 100644
index 0000000000..93fe9409aa
--- /dev/null
+++ b/development/jupyterlab/jupyterlab.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=JupyterLab
+Comment=Run JupyterLab
+Exec=jupyter-lab %f
+Terminal=true
+Type=Application
+Icon=jupyterlab
+StartupNotify=true
+MimeType=application/x-ipynb+json;
+Categories=Development;Education;
+Keywords=python;
diff --git a/development/jupyterlab/jupyterlab.info b/development/jupyterlab/jupyterlab.info
index 11c50e513a..adab7681d4 100644
--- a/development/jupyterlab/jupyterlab.info
+++ b/development/jupyterlab/jupyterlab.info
@@ -1,10 +1,10 @@
PRGNAM="jupyterlab"
-VERSION="3.5.0"
+VERSION="3.5.3"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyterlab/jupyterlab-3.5.0.tar.gz"
-MD5SUM="cf95c35acf6c184fcc9db865ce21d0ac"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyterlab/jupyterlab-3.5.3.tar.gz"
+MD5SUM="4b339d6c521fb12314a5b540512f6d85"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="jupyter-notebook_shim nodejs jupyterlab_server jupyter-ipykernel"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"