summaryrefslogtreecommitdiffstats
path: root/development/jupyter_server
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter_server')
-rw-r--r--development/jupyter_server/jupyter_server.SlackBuild17
-rw-r--r--development/jupyter_server/jupyter_server.info10
2 files changed, 14 insertions, 13 deletions
diff --git a/development/jupyter_server/jupyter_server.SlackBuild b/development/jupyter_server/jupyter_server.SlackBuild
index 6eb7cae70c..06df117e8e 100644
--- a/development/jupyter_server/jupyter_server.SlackBuild
+++ b/development/jupyter_server/jupyter_server.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter_server
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter_server
-VERSION=${VERSION:-1.23.2}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.10.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,13 +76,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.md COPYING.md README.md RELEASE.md CONTRIBUTING.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md README.md RELEASE.md CONTRIBUTING.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/jupyter_server/jupyter_server.info b/development/jupyter_server/jupyter_server.info
index 6c1437f255..f9f9853f05 100644
--- a/development/jupyter_server/jupyter_server.info
+++ b/development/jupyter_server/jupyter_server.info
@@ -1,10 +1,10 @@
PRGNAM="jupyter_server"
-VERSION="1.23.2"
+VERSION="2.10.0"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyter_server/jupyter_server-1.23.2.tar.gz"
-MD5SUM="ca2858f8a8672e465a9a888a1e79b511"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyter_server/jupyter_server-2.10.0.tar.gz"
+MD5SUM="322b630244d4dddf3db54e5c2d7a58de"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="argon2-cffi jupyter-nbconvert jupyter_packaging python3-anyio python-prometheus_client python3-requests-unixsocket send2trash terminado python3-websocket-client"
+REQUIRES="python3-argon2-cffi jupyter_events jupyter-nbconvert jupyter_server_terminals python3-anyio python3-hatch_jupyter_builder python3-prometheus_client send2trash python3-overrides python3-websocket-client"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"