summaryrefslogtreecommitdiffstats
path: root/development/jupyter-notebook_shim/jupyter-notebook_shim.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-notebook_shim/jupyter-notebook_shim.SlackBuild')
-rw-r--r--development/jupyter-notebook_shim/jupyter-notebook_shim.SlackBuild30
1 files changed, 7 insertions, 23 deletions
diff --git a/development/jupyter-notebook_shim/jupyter-notebook_shim.SlackBuild b/development/jupyter-notebook_shim/jupyter-notebook_shim.SlackBuild
index 40eb4ebca8..098b0da54b 100644
--- a/development/jupyter-notebook_shim/jupyter-notebook_shim.SlackBuild
+++ b/development/jupyter-notebook_shim/jupyter-notebook_shim.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter-notebook_shim
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-notebook_shim
-VERSION=${VERSION:-0.1.0}
+VERSION=${VERSION:-0.2.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,16 +64,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix /etc/jupyter path
-sed 's|etc|/etc|' -i setup.cfg
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
-python3 setup.py install --root=$PKG
+# Fix /etc/jupyter path
+mv $PKG/{usr/,}etc
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.md README.md RELEASE.md LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md README.md RELEASE.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install