summaryrefslogtreecommitdiffstats
path: root/development/jupyter-nbclient/jupyter-nbclient.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-nbclient/jupyter-nbclient.SlackBuild')
-rw-r--r--development/jupyter-nbclient/jupyter-nbclient.SlackBuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/development/jupyter-nbclient/jupyter-nbclient.SlackBuild b/development/jupyter-nbclient/jupyter-nbclient.SlackBuild
index 8ebbb62fb9..83223b5078 100644
--- a/development/jupyter-nbclient/jupyter-nbclient.SlackBuild
+++ b/development/jupyter-nbclient/jupyter-nbclient.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for jupyter-nbclient
# Copyright 2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-nbclient
-VERSION=${VERSION:-0.6.5}
+VERSION=${VERSION:-0.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -82,15 +79,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- *.md LICENSE PKG-INFO *.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install