summaryrefslogtreecommitdiffstats
path: root/development/jupyter-nbclassic
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-nbclassic')
-rw-r--r--development/jupyter-nbclassic/README7
-rw-r--r--development/jupyter-nbclassic/doinst.sh9
-rw-r--r--development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild103
-rw-r--r--development/jupyter-nbclassic/jupyter-nbclassic.info10
-rw-r--r--development/jupyter-nbclassic/slack-desc19
5 files changed, 148 insertions, 0 deletions
diff --git a/development/jupyter-nbclassic/README b/development/jupyter-nbclassic/README
new file mode 100644
index 0000000000..c2cc8f6699
--- /dev/null
+++ b/development/jupyter-nbclassic/README
@@ -0,0 +1,7 @@
+NBClassic runs the Jupyter Notebook frontend on the Jupyter Server
+backend.
+
+This project prepares for a future where JupyterLab and other frontends
+switch to Jupyter Server for their Python Web application backend.
+Using this package, users can launch Jupyter Notebook, JupyterLab and
+other frontends side-by-side on top of the new Python server backend.
diff --git a/development/jupyter-nbclassic/doinst.sh b/development/jupyter-nbclassic/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/development/jupyter-nbclassic/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild b/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
new file mode 100644
index 0000000000..104abca582
--- /dev/null
+++ b/development/jupyter-nbclassic/jupyter-nbclassic.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/bash
+
+# Slackware build script for jupyter-nbclassic
+
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=jupyter-nbclassic
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=nbclassic
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix /etc/jupyter path
+sed 's|etc|/etc|' -i setup.cfg
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Remove bundled mathjax2; replace with system mathjax2
+PYTHONPATH=$(python3 -c "from sysconfig import get_path; print(get_path('platlib'))")
+rm -r $PKG/$PYTHONPATH/nbclassic/static/components/MathJax
+ln -sr /usr/share/mathjax2 $PKG/$PYTHONPATH/nbclassic/static/components/MathJax
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.rst LICENSE README.md RELEASE.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyter-nbclassic/jupyter-nbclassic.info b/development/jupyter-nbclassic/jupyter-nbclassic.info
new file mode 100644
index 0000000000..e2b910cdbc
--- /dev/null
+++ b/development/jupyter-nbclassic/jupyter-nbclassic.info
@@ -0,0 +1,10 @@
+PRGNAM="jupyter-nbclassic"
+VERSION="1.0.0"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nbclassic/nbclassic-1.0.0.tar.gz"
+MD5SUM="a3db6639db4654d27cddfde666cd5ef8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jupyter-notebook_shim mathjax2"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"
diff --git a/development/jupyter-nbclassic/slack-desc b/development/jupyter-nbclassic/slack-desc
new file mode 100644
index 0000000000..4d1c1d7ad7
--- /dev/null
+++ b/development/jupyter-nbclassic/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jupyter-nbclassic: jupyter-nbclassic (Jupyter Notebook as a Jupyter Server Extension)
+jupyter-nbclassic:
+jupyter-nbclassic: NBClassic runs the Jupyter Notebook frontend on the Jupyter Server
+jupyter-nbclassic: backend.
+jupyter-nbclassic:
+jupyter-nbclassic:
+jupyter-nbclassic:
+jupyter-nbclassic:
+jupyter-nbclassic:
+jupyter-nbclassic:
+jupyter-nbclassic: