summaryrefslogtreecommitdiffstats
path: root/development/jupyter-ipywidgets/jupyter-ipywidgets.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-ipywidgets/jupyter-ipywidgets.SlackBuild')
-rw-r--r--development/jupyter-ipywidgets/jupyter-ipywidgets.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/development/jupyter-ipywidgets/jupyter-ipywidgets.SlackBuild b/development/jupyter-ipywidgets/jupyter-ipywidgets.SlackBuild
index 78f3742965..050f4520df 100644
--- a/development/jupyter-ipywidgets/jupyter-ipywidgets.SlackBuild
+++ b/development/jupyter-ipywidgets/jupyter-ipywidgets.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter-ipywidgets
-# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
SRCNAM=ipywidgets
PRGNAM=jupyter-$SRCNAM
VERSION=${VERSION:-7.4.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true