summaryrefslogtreecommitdiffstats
path: root/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild')
-rw-r--r--development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild54
1 files changed, 5 insertions, 49 deletions
diff --git a/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild b/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild
index 81a34bd7a4..9d26c85608 100644
--- a/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild
+++ b/development/jupyter-ipykernel/jupyter-ipykernel.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for jupyter-ipykernel
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-ipykernel
-VERSION=${VERSION:-6.15.3}
+VERSION=${VERSION:-6.29.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,42 +65,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from distutils.core import setup
-from glob import glob
-from ipykernel.kernelspec import KERNEL_NAME, make_ipkernel_cmd, write_kernel_spec
-import os
-import shutil
-here = os.path.abspath(os.path.dirname(__file__))
-pjoin = os.path.join
-packages = []
-for d, _, _ in os.walk(pjoin(here, 'ipykernel')):
- if os.path.exists(pjoin(d, '__init__.py')):
- packages.append(d[len(here)+1:].replace(os.path.sep, '.'))
-dest = pjoin(here, "data_kernelspec")
-if os.path.exists(dest):
- shutil.rmtree(dest)
-write_kernel_spec(dest, overrides={"argv": make_ipkernel_cmd()})
-setup(name='${SRCNAM}',
- version='${VERSION}',
- packages=packages,
- py_modules=["ipykernel_launcher"],
- data_files=[(pjoin("share", "jupyter", "kernels", KERNEL_NAME), glob(pjoin("data_kernelspec", "*")))],
- package_data={"ipykernel": ["resources/*.*", "py.typed"]},
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- *.md PKG-INFO \
+ CHANGELOG.md CONTRIBUTING.md README.md RELEASE.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild