summaryrefslogtreecommitdiffstats
path: root/development/inform/destdir.diff
diff options
context:
space:
mode:
Diffstat (limited to 'development/inform/destdir.diff')
-rw-r--r--development/inform/destdir.diff28
1 files changed, 15 insertions, 13 deletions
diff --git a/development/inform/destdir.diff b/development/inform/destdir.diff
index c85bbf9563..3713cf2fd3 100644
--- a/development/inform/destdir.diff
+++ b/development/inform/destdir.diff
@@ -1,16 +1,16 @@
-diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
---- inform-6.35-r2/Makefile 2021-06-22 00:31:25.000000000 -0400
-+++ inform-6.35-r2.patched/Makefile 2021-09-01 15:38:28.641094355 -0400
-@@ -155,7 +155,7 @@
- strip $(BINNAME)
+diff -Naur inform-6.41-r2/Makefile inform-6.41-r2.patched/Makefile
+--- inform-6.41-r2/Makefile 2022-11-21 19:31:13.000000000 -0500
++++ inform-6.41-r2.patched/Makefile 2023-01-18 15:22:43.134613101 -0500
+@@ -178,7 +178,7 @@
install-compiler: $(BINNAME)
+ ifeq ($(wildcard $(DESTDIR)$(BINDIR)/$(BINNAME)),)
- install -d -m $(DIRPERM) $(DESTDIR)$(BINDIR)
+ mkdir -p -m $(DIRPERM) $(DESTDIR)$(BINDIR)
install -c -m $(BINPERM) $(BINNAME) $(DESTDIR)$(BINDIR)
-
- #########################################################
-@@ -172,24 +172,23 @@
+ cd $(DESTDIR)$(BINDIR) ; ln -sf $(BINNAME) $(NAME)
+ @echo "** Done installing compiler."
+@@ -218,24 +218,24 @@
install-stdlib-all: install-stdlib install-stdinc install-stddemos install-stdtutor
install-stdlib:
@@ -19,6 +19,7 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
- @./fixlinks.sh $(STDLIB) $(STDLIB_LINKS)
+ mkdir -p -m $(DIRPERM) $(DESTDIR)$(STDLIB)
+ install -c -m $(FILEPERM) $(wildcard ${STDSRC}/*) $(DESTDIR)$(STDLIB)
++ @./fixlinks.sh $(DESTDIR)$(STDLIB) $(STDLIB_LINKS)
@echo "** Done installing Standard Library."
install-stdinc:
@@ -43,13 +44,14 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
@echo "** Done installing Standard Library tutorials."
-@@ -206,38 +205,40 @@
+@@ -252,39 +252,41 @@
install-punywrapper:
- sed 's,^LIBPATH.*,LIBPATH=${SHAREDIR},g' $(PUNYINFORMSH) > $(PUNYINFORMSH)-scratch
+ sed 's,^LIBPATH.*,LIBPATH=$(REAL_PREFIX)/share/$(NAME),g' $(PUNYINFORMSH) > $(PUNYINFORMSH)-scratch
+ mkdir -p -m $(DIRPERM) $(DESTDIR)$(BINDIR)
install -c -m $(BINPERM) $(PUNYINFORMSH)-scratch $(DESTDIR)$(BINDIR)/$(PUNYINFORMSH)
cd $(DESTDIR)$(BINDIR) ; ln -sf $(PUNYINFORMSH) $(PUNYINFORM)
+ cd $(DESTDIR)$(BINDIR) ; ln -sf $(PUNYINFORMSH) $(PUNYINFORM)-$(COMPVERSION)
rm -f $(PUNYINFORMSH)-scratch
install-punylib:
@@ -100,9 +102,9 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
install-puny: install-punylib install-punywrapper install-punymisc install-punyhowto install-punytests install-punydocs
-@@ -246,16 +247,17 @@
+@@ -292,16 +294,17 @@
+ #############################
# Installing everything else
-
install-manual:
- install -d -m $(DIRPERM) $(MANDIR)
- install -c -m $(FILEPERM) $(MANPAGE) $(MANDIR)
@@ -120,4 +122,4 @@ diff -Naur inform-6.35-r2/Makefile inform-6.35-r2.patched/Makefile
+install-strip: all strip install
uninstall:
- rm -f $(DESTDIR)$(BINDIR)/$(BINNAME)
+ rm -f $(DESTDIR)$(BINDIR)/$(NAME)*