summaryrefslogtreecommitdiffstats
path: root/development/gsoap
diff options
context:
space:
mode:
Diffstat (limited to 'development/gsoap')
-rw-r--r--development/gsoap/gsoap.SlackBuild6
-rw-r--r--development/gsoap/gsoap.info6
-rw-r--r--development/gsoap/patches/gsoap-2.8.126-shared_libs.patch (renamed from development/gsoap/patches/gsoap-2.8.91-shared_libs.patch)68
3 files changed, 47 insertions, 33 deletions
diff --git a/development/gsoap/gsoap.SlackBuild b/development/gsoap/gsoap.SlackBuild
index 759f2d4da4..89be61470e 100644
--- a/development/gsoap/gsoap.SlackBuild
+++ b/development/gsoap/gsoap.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gsoap
-# Copyright 2009-2022 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2009-2024 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gsoap
-VERSION=${VERSION:-2.8.118}
+VERSION=${VERSION:-2.8.132}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,7 +81,7 @@ find -L . \
# Patches from Gentoo
# Build shared libraries
-patch -p1 -i $CWD/patches/gsoap-2.8.91-shared_libs.patch
+patch -p1 -i $CWD/patches/gsoap-2.8.126-shared_libs.patch
autoreconf -vif
diff --git a/development/gsoap/gsoap.info b/development/gsoap/gsoap.info
index e3dd47596a..891fdcf791 100644
--- a/development/gsoap/gsoap.info
+++ b/development/gsoap/gsoap.info
@@ -1,8 +1,8 @@
PRGNAM="gsoap"
-VERSION="2.8.118"
+VERSION="2.8.132"
HOMEPAGE="http://gsoap2.sourceforge.net/"
-DOWNLOAD="https://sourceforge.net/projects/gsoap2/files/gsoap_2.8.118.zip"
-MD5SUM="f15fd826e1f7b003beb2d9ff454f12dc"
+DOWNLOAD="https://sources.liwjatan.org/gsoap/gsoap_2.8.132.zip"
+MD5SUM="b0b93960bba760b5749f2fef3d5c718a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/development/gsoap/patches/gsoap-2.8.91-shared_libs.patch b/development/gsoap/patches/gsoap-2.8.126-shared_libs.patch
index 1fcdeeb698..86b0a56b3c 100644
--- a/development/gsoap/patches/gsoap-2.8.91-shared_libs.patch
+++ b/development/gsoap/patches/gsoap-2.8.126-shared_libs.patch
@@ -1,6 +1,7 @@
---- gsoap-2.8/configure.ac
-+++ gsoap-2.8/configure.ac
-@@ -17,7 +17,7 @@
+diff -ur gsoap-2.8.126.orig/configure.ac gsoap-2.8.126/configure.ac
+--- gsoap-2.8.126.orig/configure.ac 2023-03-09 21:56:09.000000000 +0100
++++ gsoap-2.8.126/configure.ac 2023-03-11 15:47:48.672933043 +0100
+@@ -16,7 +16,7 @@
AC_PROG_YACC
AC_PROG_CPP
AC_PROG_RANLIB
@@ -9,7 +10,7 @@
AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_INSTALL
-@@ -307,15 +307,17 @@
+@@ -310,7 +310,8 @@
WSDL2H_EXTRA_LIBS="${WSDL2H_EXTRA_LIBS} -lgnutls -lgcrypt -lgpg-error -lz"
SAMPLE_INCLUDES=
SAMPLE_SSL_LIBS="-lgnutls -lgcrypt -lgpg-error -lz"
@@ -17,20 +18,29 @@
+ WSDL2H_SOAP_CPP_STATIC_LIB="libgsoapssl++.a"
+ WSDL2H_SOAP_CPP_SHARED_LIB="libgsoapssl++.la"
else
- AC_MSG_RESULT(no)
- WSDL2H_EXTRA_FLAGS="-DWITH_OPENSSL -DWITH_GZIP"
- # compile with wsdl2h when OPENSSL is available
-- WSDL2H_EXTRA_LIBS="${WSDL2H_EXTRA_LIBS} -lssl -lcrypto -lz"
-+ WSDL2H_EXTRA_LIBS="${WSDL2H_EXTRA_LIBS} -lcrypto"
- SAMPLE_INCLUDES=
- SAMPLE_SSL_LIBS="-lssl -lcrypto -lz"
-- WSDL2H_SOAP_CPP_LIB="libgsoapssl++.a"
-+ WSDL2H_SOAP_CPP_STATIC_LIB="libgsoapssl++.a"
-+ WSDL2H_SOAP_CPP_SHARED_LIB="libgsoapssl++.la"
+ if test "x$with_wolfssl" = "xyes"; then
+ AC_MSG_RESULT(yes)
+@@ -318,7 +319,8 @@
+ WSDL2H_EXTRA_LIBS="${WSDL2H_EXTRA_LIBS} -lwolfssl -lz"
+ SAMPLE_INCLUDES=
+ SAMPLE_SSL_LIBS="-lwolfssl -lz"
+- WSDL2H_SOAP_CPP_LIB="libgsoapssl++.a"
++ WSDL2H_SOAP_CPP_STATIC_LIB="libgsoapssl++.a"
++ WSDL2H_SOAP_CPP_SHARED_LIB="libgsoapssl++.la"
+ else
+ AC_MSG_RESULT(no)
+ WSDL2H_EXTRA_FLAGS="-DWITH_OPENSSL -DWITH_GZIP"
+@@ -326,7 +328,8 @@
+ WSDL2H_EXTRA_LIBS="${WSDL2H_EXTRA_LIBS} -lssl -lcrypto -lz"
+ SAMPLE_INCLUDES=
+ SAMPLE_SSL_LIBS="-lssl -lcrypto -lz"
+- WSDL2H_SOAP_CPP_LIB="libgsoapssl++.a"
++ WSDL2H_SOAP_CPP_STATIC_LIB="libgsoapssl++.a"
++ WSDL2H_SOAP_CPP_SHARED_LIB="libgsoapssl++.la"
+ fi
fi
if test -n "$ZLIB"; then
- WSDL2H_EXTRA_FLAGS="-I${ZLIB}/include ${WSDL2H_EXTRA_FLAGS}"
-@@ -334,7 +336,8 @@
+@@ -346,14 +349,16 @@
WSDL2H_EXTRA_FLAGS=
SAMPLE_SSL_LIBS=
SAMPLE_INCLUDES=
@@ -38,9 +48,8 @@
+ WSDL2H_SOAP_CPP_STATIC_LIB="libgsoap++.a"
+ WSDL2H_SOAP_CPP_SHARED_LIB="libgsoapssl++.la"
fi
- AM_CONDITIONAL(WITH_OPENSSL, test "x$with_openssl" = "xyes" -a "x$with_gnutls" != "xyes")
- AC_SUBST(WITH_OPENSSL)
-@@ -342,7 +345,8 @@
+ AM_CONDITIONAL([WITH_OPENSSL], [test "x$with_openssl" = "xyes" -a "x$with_gnutls" != "xyes" -a "x$with_wolfssl" != "xyes"])
+ AC_SUBST(WSDL2H_EXTRA_FLAGS)
AC_SUBST(WSDL2H_EXTRA_LIBS)
AC_SUBST(SAMPLE_INCLUDES)
AC_SUBST(SAMPLE_SSL_LIBS)
@@ -50,8 +59,10 @@
# enable the compile of the samples
AC_ARG_ENABLE(samples,
---- gsoap-2.8/gsoap/Makefile.am
-+++ gsoap-2.8/gsoap/Makefile.am
+Only in gsoap-2.8.126: configure.ac.orig
+diff -ur gsoap-2.8.126.orig/gsoap/Makefile.am gsoap-2.8.126/gsoap/Makefile.am
+--- gsoap-2.8.126.orig/gsoap/Makefile.am 2023-03-09 21:56:09.000000000 +0100
++++ gsoap-2.8.126/gsoap/Makefile.am 2023-03-11 15:46:24.412936978 +0100
@@ -49,6 +49,29 @@
libgsoapssl___a_SOURCES = stdsoap2_ssl_cpp.cpp dom_cpp.cpp
libgsoapssl___a_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) $(SOAPCPP2_NO_C_LOCALE) $(SOAPCPP2_IPV6) $(SOAPCPP2_IPV6_V6ONLY) -D$(platform) $(WSDL2H_EXTRA_FLAGS) -DWITH_DOM -DWITH_COOKIES
@@ -82,8 +93,9 @@
BUILT_SOURCES = stdsoap2_cpp.cpp dom_cpp.cpp stdsoap2_ck.c stdsoap2_ck_cpp.cpp stdsoap2_ssl.c stdsoap2_ssl_cpp.cpp
include_HEADERS = stdsoap2.h
---- gsoap-2.8/gsoap/samples/autotest/Makefile.am
-+++ gsoap-2.8/gsoap/samples/autotest/Makefile.am
+diff -ur gsoap-2.8.126.orig/gsoap/samples/autotest/Makefile.am gsoap-2.8.126/gsoap/samples/autotest/Makefile.am
+--- gsoap-2.8.126.orig/gsoap/samples/autotest/Makefile.am 2023-03-09 21:56:09.000000000 +0100
++++ gsoap-2.8.126/gsoap/samples/autotest/Makefile.am 2023-03-11 15:46:24.412936978 +0100
@@ -14,7 +14,7 @@
WSDLINPUT=$(top_srcdir)/gsoap/samples/autotest/examples.wsdl
SOAPHEADER=$(top_srcdir)/gsoap/samples/autotest/examples.h
@@ -101,8 +113,9 @@
+autotest_LDADD=$(SOAP_CPP_SHARED_LIB) $(SAMPLE_EXTRA_LIBS)
CLEANFILES= *~ *.h *.cpp *.xml *.log *.nsmap
---- gsoap-2.8/gsoap/samples/databinding/Makefile.am
-+++ gsoap-2.8/gsoap/samples/databinding/Makefile.am
+diff -ur gsoap-2.8.126.orig/gsoap/samples/databinding/Makefile.am gsoap-2.8.126/gsoap/samples/databinding/Makefile.am
+--- gsoap-2.8.126.orig/gsoap/samples/databinding/Makefile.am 2023-03-09 21:56:10.000000000 +0100
++++ gsoap-2.8.126/gsoap/samples/databinding/Makefile.am 2023-03-11 15:46:24.412936978 +0100
@@ -14,7 +14,7 @@
WSDLINPUT=$(top_srcdir)/gsoap/samples/databinding/address.xsd
SOAPHEADER=$(top_srcdir)/gsoap/samples/databinding/address.h
@@ -120,8 +133,9 @@
+address_LDADD=$(SOAP_CPP_SHARED_LIB)
CLEANFILES= *~ address.h *C.cpp *H.h *Stub.h *.nsmap
---- gsoap-2.8/gsoap/wsdl/Makefile.am
-+++ gsoap-2.8/gsoap/wsdl/Makefile.am
+diff -ur gsoap-2.8.126.orig/gsoap/wsdl/Makefile.am gsoap-2.8.126/gsoap/wsdl/Makefile.am
+--- gsoap-2.8.126.orig/gsoap/wsdl/Makefile.am 2023-03-09 21:56:11.000000000 +0100
++++ gsoap-2.8.126/gsoap/wsdl/Makefile.am 2023-03-11 15:46:24.412936978 +0100
@@ -10,7 +10,7 @@
AM_LDFLAGS=-L$(top_srcdir)/gsoap/wsdl -I$(top_srcdir)/gsoap -I$(top_srcdir)/gsoap/plugin
AM_CPPFLAGS=-I$(top_srcdir)/gsoap -I$(top_srcdir)/gsoap/plugin