summaryrefslogtreecommitdiffstats
path: root/development/gnuradio/gnuradio-cppunit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'development/gnuradio/gnuradio-cppunit.patch')
-rw-r--r--development/gnuradio/gnuradio-cppunit.patch72
1 files changed, 0 insertions, 72 deletions
diff --git a/development/gnuradio/gnuradio-cppunit.patch b/development/gnuradio/gnuradio-cppunit.patch
deleted file mode 100644
index 01f58f396d..0000000000
--- a/development/gnuradio/gnuradio-cppunit.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0ac65fe..71378aa 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -62,7 +62,7 @@ ENDIF()
- # set(CMAKE_CXX_STANDARD 98)
-
- IF(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
-- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
-+# SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
- ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
- ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
-@@ -72,7 +72,7 @@ ELSE()
- ENDIF()
-
- IF(CMAKE_C_COMPILER_ID STREQUAL "GNU")
-- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
-+# SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
- ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
- ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "MSVC")
-diff --git a/gnuradio-runtime/lib/math/qa_fxpt.h b/gnuradio-runtime/lib/math/qa_fxpt.h
-index 58a6f02..6020e47 100644
---- a/gnuradio-runtime/lib/math/qa_fxpt.h
-+++ b/gnuradio-runtime/lib/math/qa_fxpt.h
-@@ -25,6 +25,7 @@
-
- #include <cppunit/extensions/HelperMacros.h>
- #include <cppunit/TestCase.h>
-+#include <memory>
-
- class qa_fxpt : public CppUnit::TestCase
- {
-diff --git a/gnuradio-runtime/lib/math/qa_fxpt_nco.h b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
-index 1b2cdae..1755904 100644
---- a/gnuradio-runtime/lib/math/qa_fxpt_nco.h
-+++ b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
-@@ -25,6 +25,7 @@
-
- #include <cppunit/extensions/HelperMacros.h>
- #include <cppunit/TestCase.h>
-+#include <memory>
-
- class qa_fxpt_nco : public CppUnit::TestCase
- {
-diff --git a/gnuradio-runtime/lib/math/qa_fxpt_vco.h b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
-index 72693f3..76e0b6d 100644
---- a/gnuradio-runtime/lib/math/qa_fxpt_vco.h
-+++ b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
-@@ -25,6 +25,7 @@
-
- #include <cppunit/extensions/HelperMacros.h>
- #include <cppunit/TestCase.h>
-+#include <memory>
-
- class qa_fxpt_vco : public CppUnit::TestCase
- {
-diff --git a/gr-fec/include/gnuradio/fec/polar_decoder_common.h b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
-index 13b25ea..8a3d65d 100644
---- a/gr-fec/include/gnuradio/fec/polar_decoder_common.h
-+++ b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
-@@ -68,7 +68,7 @@ namespace gr {
- bool set_frame_size(unsigned int frame_size){return false;};
-
- private:
-- static BOOST_CONSTEXPR_OR_CONST float D_LLR_FACTOR;
-+ static const float D_LLR_FACTOR;
- unsigned int d_frozen_bit_counter;
-
- protected:
-