summaryrefslogtreecommitdiffstats
path: root/development/gedit/gedit.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/gedit/gedit.SlackBuild')
-rw-r--r--development/gedit/gedit.SlackBuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/development/gedit/gedit.SlackBuild b/development/gedit/gedit.SlackBuild
index f2c9e4ffe2..44f2c358eb 100644
--- a/development/gedit/gedit.SlackBuild
+++ b/development/gedit/gedit.SlackBuild
@@ -27,10 +27,15 @@
# Special thanks to Brandon Pribula, who kindly handed over maintenance to me.
+# 20231207 bkw: modified by SlackBuilds.org: remove gspell
+# autodetection (redundant; gspell is a required dep, plus it was
+# breaking the build on -current). Thanks to UrbanMusic on Libera IRC
+# for pointing this out.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gedit
-VERSION=${VERSION:-42.2}
+VERSION=${VERSION:-46.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,19 +86,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# gspell is an optional (autodetected) dependency. Give the user the possibility of
-# disabling it if preinstalled.
-spell='disabled'
-if [ -f /usr/lib${LIBDIRSUFFIX}/libgspell-1.so ] && [ "${WITH_GSPELL:-yes}" != "no" ]; then
- spell='enabled'
-fi;
-# Allow the user to disable user documentation inclusion
-[ "${WITH_USER_DOCS:-yes}" != "no" ] && WITH_USER_DOCS="true" || WITH_USER_DOCS="false"
+# circunvent meson version mismtach (fs.copyfile not available)
+# avoid gtk_doc, which uses fs.copyfile
+# replace unnecesary version bump of gio-2.0
+sed -i "s/meson_version: '>= 0.64'/meson_version: '>= 0.59'/;
+ s/'gio-2.0', version: '>= 2.74'/'gio-2.0', version: '>= 2.70'/" meson.build
+
-mkdir build
cd build
- CFLAGS="$SLKCFLAGS" \
+ CFLAGS="$SLKCFLAGS -DG_CONNECT_DEFAULT=0" \
CXXFLAGS="$SLKCFLAGS" \
meson .. \
--buildtype=release \
@@ -103,8 +105,7 @@ cd build
--mandir=/usr/man \
--prefix=/usr \
--sysconfdir=/etc \
- -Dspell=$spell \
- -Duser_documentation=${WITH_USER_DOCS} \
+ -Dgtk_doc=false \
-Dstrip=true
"${NINJA:=ninja}"
DESTDIR=$PKG $NINJA install