summaryrefslogtreecommitdiffstats
path: root/development/aflplusplus/build_qemu_support.diff
diff options
context:
space:
mode:
Diffstat (limited to 'development/aflplusplus/build_qemu_support.diff')
-rw-r--r--development/aflplusplus/build_qemu_support.diff28
1 files changed, 17 insertions, 11 deletions
diff --git a/development/aflplusplus/build_qemu_support.diff b/development/aflplusplus/build_qemu_support.diff
index b9a28a6bfd..ab4321ca2b 100644
--- a/development/aflplusplus/build_qemu_support.diff
+++ b/development/aflplusplus/build_qemu_support.diff
@@ -1,12 +1,10 @@
-diff -Naur AFLplusplus-3.14c/qemu_mode/build_qemu_support.sh AFLplusplus-3.14c.patched/qemu_mode/build_qemu_support.sh
---- AFLplusplus-3.14c/qemu_mode/build_qemu_support.sh 2021-07-19 04:50:09.000000000 -0400
-+++ AFLplusplus-3.14c.patched/qemu_mode/build_qemu_support.sh 2021-08-08 13:20:14.656823570 -0400
-@@ -68,36 +68,8 @@
+diff -Naur AFLplusplus-4.04c/qemu_mode/build_qemu_support.sh AFLplusplus-4.04c.patched/qemu_mode/build_qemu_support.sh
+--- AFLplusplus-4.04c/qemu_mode/build_qemu_support.sh 2022-10-11 09:40:55.000000000 -0400
++++ AFLplusplus-4.04c.patched/qemu_mode/build_qemu_support.sh 2022-12-29 17:08:26.492717555 -0500
+@@ -70,35 +70,7 @@
- echo "[+] All checks passed!"
+ echo "[*] Making sure qemuafl is checked out"
--echo "[*] Making sure qemuafl is checked out"
--
-git status 1>/dev/null 2>/dev/null
-if [ $? -eq 0 ]; then
- echo "[*] initializing qemuafl submodule"
@@ -14,9 +12,9 @@ diff -Naur AFLplusplus-3.14c/qemu_mode/build_qemu_support.sh AFLplusplus-3.14c.p
- git submodule update ./qemuafl 2>/dev/null # ignore errors
-else
- echo "[*] cloning qemuafl"
-- test -d qemuafl || {
+- test -d qemuafl/.git || {
- CNT=1
-- while [ '!' -d qemuafl -a "$CNT" -lt 4 ]; do
+- while [ '!' -d qemuafl/.git -a "$CNT" -lt 4 ]; do
- echo "Trying to clone qemuafl (attempt $CNT/3)"
- git clone --depth 1 https://github.com/AFLplusplus/qemuafl
- CNT=`expr "$CNT" + 1`
@@ -24,7 +22,7 @@ diff -Naur AFLplusplus-3.14c/qemu_mode/build_qemu_support.sh AFLplusplus-3.14c.p
- }
-fi
-
--test -d qemuafl || { echo "[-] Not checked out, please install git or check your internet connection." ; exit 1 ; }
+-test -e qemuafl/.git || { echo "[-] Not checked out, please install git or check your internet connection." ; exit 1 ; }
-echo "[+] Got qemuafl."
-
cd "qemuafl" || exit 1
@@ -33,9 +31,17 @@ diff -Naur AFLplusplus-3.14c/qemu_mode/build_qemu_support.sh AFLplusplus-3.14c.p
-else
- echo "[*] Checking out $QEMUAFL_VERSION"
- sh -c 'git stash' 1>/dev/null 2>/dev/null
+- git pull
- git checkout "$QEMUAFL_VERSION" || echo Warning: could not check out to commit $QEMUAFL_VERSION
-fi
-+sed -i '/hexagon/d' target/meson.build # broken!
echo "[*] Making sure imported headers matches"
cp "../../include/config.h" "./qemuafl/imported/" || exit 1
+@@ -239,7 +211,6 @@
+ --enable-debug-stack-usage \
+ --enable-debug-tcg \
+ --enable-qom-cast-debug \
+- --enable-werror \
+ "
+
+ else