summaryrefslogtreecommitdiffstats
path: root/desktop/wmmon/patches/gcc5.diff
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/wmmon/patches/gcc5.diff')
-rw-r--r--desktop/wmmon/patches/gcc5.diff18
1 files changed, 18 insertions, 0 deletions
diff --git a/desktop/wmmon/patches/gcc5.diff b/desktop/wmmon/patches/gcc5.diff
new file mode 100644
index 0000000000..1d02bddb48
--- /dev/null
+++ b/desktop/wmmon/patches/gcc5.diff
@@ -0,0 +1,18 @@
+Description: fix build failure with gcc5:
+ build with "-std=gnu89"
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/778171
+Author: gregor herrmann <gregoa@debian.org>
+Last-Update: 2015-07-19
+
+--- a/wmmon/Makefile
++++ b/wmmon/Makefile
+@@ -5,7 +5,7 @@
+ ../wmgeneral/misc.o \
+ ../wmgeneral/list.o
+
+-CFLAGS = -O2
++CFLAGS = -O2 -std=gnu89
+ CC = cc
+
+