summaryrefslogtreecommitdiffstats
path: root/desktop/sun
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/sun')
-rw-r--r--desktop/sun/README7
-rw-r--r--desktop/sun/doinst.sh6
-rw-r--r--desktop/sun/slack-desc10
-rw-r--r--desktop/sun/sun.SlackBuild22
-rw-r--r--desktop/sun/sun.info12
5 files changed, 41 insertions, 16 deletions
diff --git a/desktop/sun/README b/desktop/sun/README
index b7adb3ff77..8c873a01f5 100644
--- a/desktop/sun/README
+++ b/desktop/sun/README
@@ -1,3 +1,10 @@
SUN (Slackware Update Notifier) is a tray notification applet
for informing about package updates in Slackware and CLI tool for
monitoring upgraded packages.
+
+SUN works with slackpkg as well as with others tools and
+repositories. Probably, you can use the SUN with other's Slackware
+based Linux distributionsc as well.
+
+Edit the configuration /etc/sun/repositories.toml file and change the
+http mirror for your country. NOTE: ftp mirrors not supported.
diff --git a/desktop/sun/doinst.sh b/desktop/sun/doinst.sh
index 5dc84af9c0..f59a2090af 100644
--- a/desktop/sun/doinst.sh
+++ b/desktop/sun/doinst.sh
@@ -8,8 +8,12 @@ config() {
fi
}
-config etc/sun/sun.conf.new
+config etc/sun/sun.toml.new
+config etc/sun/repositories.toml.new
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+cmp etc/xdg/autostart/sun-daemon.desktop etc/xdg/autostart/sun-daemon.desktop.sample 2> /dev/null && \
+ rm etc/xdg/autostart/sun-daemon.desktop.sample
diff --git a/desktop/sun/slack-desc b/desktop/sun/slack-desc
index 6df4357611..35d6b0e7f2 100644
--- a/desktop/sun/slack-desc
+++ b/desktop/sun/slack-desc
@@ -9,11 +9,11 @@
sun: sun (Slackware Update Notifier)
sun:
sun: SUN is a tray notification applet for informing about package updates
-sun: in Slackware and CLI tool for monitoring upgraded packages.
-sun:
-sun: Homepage: https://gitlab.com/dslackw/sun
-sun:
-sun:
+sun: in Slackware and CLI tool for monitoring upgraded packages. SUN works
+sun: with slackpkg as well as with others tools and repositories. Probably
+sun: you can use the SUN with other's Slackware based Linux distributions
+sun: as well.
sun:
+sun: Homepage: https://dslackw.gitlab.io/sun
sun:
sun:
diff --git a/desktop/sun/sun.SlackBuild b/desktop/sun/sun.SlackBuild
index b880f66b15..8b1e188539 100644
--- a/desktop/sun/sun.SlackBuild
+++ b/desktop/sun/sun.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sun
-# Copyright 2015-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sun
-VERSION=${VERSION:-1.3.5}
+VERSION=${VERSION:-1.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,13 +79,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+# Install configuration and data files
+mkdir -p $PKG/usr/sbin $PKG/etc/$PRGNAM $PKG/usr/share/pixmaps/ $PKG/usr/share/applications/ \
+ $PKG/etc/xdg/autostart/
+
+install -D -m0644 conf/sun.toml $PKG/etc/sun/sun.toml.new
+install -D -m0644 conf/repositories.toml $PKG/etc/sun/repositories.toml.new
+
+mv $PKG/usr/bin/sun-autostart $PKG/usr/sbin/
+cp -a extra/icon/sun.png $PKG/usr/share/pixmaps/
+cp -a extra/desktop/sun.desktop $PKG/usr/share/applications/
+cp -a extra/xdg/sun-daemon.desktop.sample $PKG/etc/xdg/autostart/
+cp -a extra/xdg/sun.desktop $PKG/etc/xdg/autostart/
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.md LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md CHANGELOG.md LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/desktop/sun/sun.info b/desktop/sun/sun.info
index e5122609d4..c218c6b12d 100644
--- a/desktop/sun/sun.info
+++ b/desktop/sun/sun.info
@@ -1,10 +1,10 @@
PRGNAM="sun"
-VERSION="1.3.5"
-HOMEPAGE="https://gitlab.com/dslackw/sun"
-DOWNLOAD="https://gitlab.com/dslackw/sun/-/archive/1.3.5/sun-1.3.5.tar.gz"
-MD5SUM="15974b174d907ece9577f39b2ad6ea41"
+VERSION="1.6.2"
+HOMEPAGE="https://dslackw.gitlab.io/sun"
+DOWNLOAD="https://gitlab.com/dslackw/sun/-/archive/1.6.2/sun-1.6.2.tar.gz"
+MD5SUM="06875ba5633252d88876c77e7f147e73"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"