summaryrefslogtreecommitdiffstats
path: root/desktop/rsl/rsl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/rsl/rsl.SlackBuild')
-rw-r--r--desktop/rsl/rsl.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/desktop/rsl/rsl.SlackBuild b/desktop/rsl/rsl.SlackBuild
index c3cd5e0cb3..d68bd92cab 100644
--- a/desktop/rsl/rsl.SlackBuild
+++ b/desktop/rsl/rsl.SlackBuild
@@ -4,7 +4,7 @@
# Written by stormtracknole <stormtracknole@gmail.com>
PRGNAM=rsl
-VERSION=${VERSION:-1.40}
+VERSION=${VERSION:-1.44}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,6 +50,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Hack to get rsl to build against newer flex.
+sed -i 's|\$LEXLIB||' configure.ac
+autoreconf -ivf
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \