summaryrefslogtreecommitdiffstats
path: root/desktop/qtile
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/qtile')
-rw-r--r--desktop/qtile/README19
-rw-r--r--desktop/qtile/qtile.SlackBuild30
-rw-r--r--desktop/qtile/qtile.info10
-rw-r--r--desktop/qtile/slack-desc10
-rw-r--r--desktop/qtile/xinitrc.qtile4
5 files changed, 31 insertions, 42 deletions
diff --git a/desktop/qtile/README b/desktop/qtile/README
index 5905765087..a41008c12a 100644
--- a/desktop/qtile/README
+++ b/desktop/qtile/README
@@ -1,14 +1,15 @@
-Qtile is simple, small, and extensible. It's easy to write your own
-layouts, widgets, and built-in commands. Qtile is written and configured
-entirely in Python, which means you can leverage the full power and
-flexibility of the language to make it fit your needs.
+Qtile is a full-featured, hackable tiling window manager (X11 or
+Wayland) written and configured in Python. Qtile is simple, small, and
+extensible - it is easy to write your own layouts, widgets and built-in
+commands.
-You will need to build cairocffi with its optional python3-xcffib
-dependency.
+You will need to build python3-cairocffi with its optional
+python3-xcffib dependency.
-python-dbus-next is an optional dependency for qtile.
+python3-dbus-next is an optional dependency for qtile.
It sends notifications through dbus - please additionally install a
notification daemon such as dunst for displaying notifications on qtile.
-pywlroots (another optional dependency) provides experimental Wayland
-support.
+This SlackBuild does not provide Wayland support. Slackware 15.0 is only
+able to build wlroots 0.15. qtile >= 0.26.0 requires wlroots 0.17 (which
+cannot be built with Slackware 15).
diff --git a/desktop/qtile/qtile.SlackBuild b/desktop/qtile/qtile.SlackBuild
index 4d5e4f27c1..c9f953c731 100644
--- a/desktop/qtile/qtile.SlackBuild
+++ b/desktop/qtile/qtile.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for qtile
# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qtile
-VERSION=${VERSION:-0.21.0}
+VERSION=${VERSION:-0.28.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -80,7 +63,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+# qtile provides a setup.py - however, setuptools > 58.2.0 does not recommend running setup.py directly
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -89,7 +77,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/etc/X11/xinit
install -m 0755 $CWD/xinitrc.$PRGNAM $PKG/etc/X11/xinit/xinitrc.$PRGNAM
-# Install desktop file
+# Install Xsession file
mkdir -p $PKG/usr/share/xsessions
install -D -m644 resources/$PRGNAM.desktop $PKG/usr/share/xsessions/$PRGNAM.desktop
diff --git a/desktop/qtile/qtile.info b/desktop/qtile/qtile.info
index 770c3fd909..625c287a31 100644
--- a/desktop/qtile/qtile.info
+++ b/desktop/qtile/qtile.info
@@ -1,10 +1,10 @@
PRGNAM="qtile"
-VERSION="0.21.0"
+VERSION="0.28.1"
HOMEPAGE="http://qtile.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/a4/7e/4f3921eda7e3912aa7487b0455e1993a638d99cf6075205de3cf8a13f291/qtile-0.21.0.tar.gz"
-MD5SUM="91a9691e69459bc690c335a2f4b4e18a"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/q/qtile/qtile-0.28.1.tar.gz"
+MD5SUM="ef53525da2b6f6e7fefef13c73f3d7ac"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-xcffib cairocffi"
+REQUIRES="python3-xcffib python3-cairocffi python3-setuptools-scm-opt"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"
diff --git a/desktop/qtile/slack-desc b/desktop/qtile/slack-desc
index 32b9a0b3e1..30f1630269 100644
--- a/desktop/qtile/slack-desc
+++ b/desktop/qtile/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
qtile: qtile (tiling window manager)
qtile:
-qtile: Qtile is simple, small, and extensible. It's easy to write your own
-qtile: layouts, widgets, and built-in commands. Qtile is written and
-qtile: configured entirely in Python, which means you can leverage the full
-qtile: power and flexibility of the language to make it fit your needs.
+qtile: Qtile is a full-featured, hackable tiling window manager (X11 or
+qtile: Wayland) written and configured in Python.
+qtile:
+qtile: Homepage: https://qtile.org
+qtile:
qtile:
-qtile: Homepage: http://qtile.org
qtile:
qtile:
qtile:
diff --git a/desktop/qtile/xinitrc.qtile b/desktop/qtile/xinitrc.qtile
index a2c7cde278..b23bc7c340 100644
--- a/desktop/qtile/xinitrc.qtile
+++ b/desktop/qtile/xinitrc.qtile
@@ -24,7 +24,7 @@ fi
# Start qtile
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
- exec ck-launch-session qtile
+ exec ck-launch-session dbus-launch --exit-with-session qtile start
else
- exec qtile
+ exec dbus-launch --exit-with-session qtile start
fi