summaryrefslogtreecommitdiffstats
path: root/desktop/py3status/py3status.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/py3status/py3status.SlackBuild')
-rw-r--r--desktop/py3status/py3status.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/desktop/py3status/py3status.SlackBuild b/desktop/py3status/py3status.SlackBuild
index c267199554..3108d7ee17 100644
--- a/desktop/py3status/py3status.SlackBuild
+++ b/desktop/py3status/py3status.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for py3status
-# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=py3status
-VERSION=${VERSION:-3.45}
+VERSION=${VERSION:-3.55}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true