summaryrefslogtreecommitdiffstats
path: root/desktop/nwg-shell
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/nwg-shell')
-rw-r--r--desktop/nwg-shell/README40
-rw-r--r--desktop/nwg-shell/doinst.sh3
-rw-r--r--desktop/nwg-shell/nwg-shell.SlackBuild113
-rw-r--r--desktop/nwg-shell/nwg-shell.info10
-rw-r--r--desktop/nwg-shell/slack-desc19
-rw-r--r--desktop/nwg-shell/slackware.diff371
6 files changed, 556 insertions, 0 deletions
diff --git a/desktop/nwg-shell/README b/desktop/nwg-shell/README
new file mode 100644
index 0000000000..76012273a1
--- /dev/null
+++ b/desktop/nwg-shell/README
@@ -0,0 +1,40 @@
+nwg-shell (base shell and utils for Sway-based shell)
+
+Base package of utils and configurations for nwg-shell.
+
+This package acts as a meta-package to pull in all
+the dependencies for building the entire nwg-shell
+project.
+
+Installation of the nwg-shell WM on Slackware:
+
+First build/install this package and all of
+the dependencies.
+
+Ensure your $USER is in the 'video' group.
+
+1. Run (as $USER) 'xdg-user-dirs-update'
+ (first launch only)
+2. then Run 'nwg-shell-installer -a'
+ (installs default skeleton config)
+3. Launch 'sway'
+
+After initial setup, one need only exec
+'sway' to load nwg-shell.
+
+By default nwg-shell uses:
+-playerctl (media player)
+-Firefox (web browsing)
+-mousepad (text editor)
+-thunar (file explorer)
+-gtklock (lockscreen)
+
+Ensure you have a full Slackware install
+(or everything but /kde). Default apps are
+from XFCE, so ensure you've installed the
+xfce/ package series.
+
+All defaults are user configurable within the WM.
+
+The nwg-shell project now has a optional graphical
+greeter based on greetd. Check out 'nwg-hello' on SBo!
diff --git a/desktop/nwg-shell/doinst.sh b/desktop/nwg-shell/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/nwg-shell/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/nwg-shell/nwg-shell.SlackBuild b/desktop/nwg-shell/nwg-shell.SlackBuild
new file mode 100644
index 0000000000..4d06bc8821
--- /dev/null
+++ b/desktop/nwg-shell/nwg-shell.SlackBuild
@@ -0,0 +1,113 @@
+#!/bin/bash
+
+# Slackware build script for nwg-shell
+
+# Copyright 2023-2024 Jay Lanagan (j@lngn.net), Detroit, MI, USA.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nwg-shell
+VERSION=${VERSION:-0.5.34}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-v$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+
+# patches removing refs to systemctl & replaced w/ loginctl & disable updater
+patch -Np1 -i $CWD/slackware.diff || exit 1
+
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --optimize=1 --root=$PKG
+install -Dm0644 -t $PKG/usr/share/backgrounds nwg-shell.jpg
+install -Dm0755 -t $PKG/usr/bin scripts/screenshot
+install -Dm0644 -t $PKG/usr/share/applications nwg-readme.desktop
+
+# Remove Arch updaters from our Slackware package, users are recommended
+# to use sbopkg, sboui, or their favorite SBo updater to get package updates.
+rm $PKG/usr/bin/nwg-shell-check-updates
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/nwg-shell/nwg-shell.info b/desktop/nwg-shell/nwg-shell.info
new file mode 100644
index 0000000000..bf256e983b
--- /dev/null
+++ b/desktop/nwg-shell/nwg-shell.info
@@ -0,0 +1,10 @@
+PRGNAM="nwg-shell"
+VERSION="0.5.34"
+HOMEPAGE="https://nwg-piotr.github.io/nwg-shell/"
+DOWNLOAD="https://github.com/nwg-piotr/nwg-shell/releases/download/v0.5.34/nwg-shell-v0.5.34.tar.gz"
+MD5SUM="3cfa51cb7d68c5d93a58c69a738e9857"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="foot grim jq brightnessctl papirus-icon-theme slurp gtklock-playerctl-module gtklock-powerbar-module gtklock-userinfo-module swappy sway swayidle swaylock wl-clipboard azote gopsuinfo nwg-bar nwg-clipman nwg-dock nwg-menu nwg-look nwg-panel nwg-readme-browser nwg-shell-config nwg-shell-wallpapers nwg-wrapper nwg-displays python3-autotiling xdg-desktop-portal-wlr"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/desktop/nwg-shell/slack-desc b/desktop/nwg-shell/slack-desc
new file mode 100644
index 0000000000..8d8eccbfa1
--- /dev/null
+++ b/desktop/nwg-shell/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+nwg-shell: nwg-shell (base shell and utils for sway-based shell)
+nwg-shell:
+nwg-shell: Base package of utils and configurations for nwg-shell.
+nwg-shell:
+nwg-shell: Homepage: https://github.com/nwg-piotr/nwg-shell
+nwg-shell:
+nwg-shell:
+nwg-shell:
+nwg-shell:
+nwg-shell:
+nwg-shell:
diff --git a/desktop/nwg-shell/slackware.diff b/desktop/nwg-shell/slackware.diff
new file mode 100644
index 0000000000..e5bdf83ece
--- /dev/null
+++ b/desktop/nwg-shell/slackware.diff
@@ -0,0 +1,371 @@
+diff -ur a/nwg_shell/installer.py b/nwg_shell/installer.py
+--- a/nwg_shell/installer.py 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/installer.py 2024-04-23 08:06:15.320307748 -0400
+@@ -173,7 +173,7 @@
+ print(" This script installs/overwrites configs and style sheets ")
+ print(" for sway, Hyprland and nwg-shell components. ")
+ print(" The only backup that will be made is the main sway config file. ")
+- print(" This script should be used on a fresh Arch Linux installation. ")
++ print(" This script should be used on a fresh Slackware installation. ")
+ print(" If you're running it on your existing setup, ")
+ print(" you're doing it at your own risk. ")
+ print("*******************************************************************")
+@@ -255,7 +255,7 @@
+ break
+
+ if "editor" not in s or not s["editor"]:
+- for cmd in ["mousepad", "atom", "emacs", "gedit", "geany", "kate", "vim"]:
++ for cmd in ["mousepad", "atom", "emacs", "gedit", "joe", "kate", "vim"]:
+ if is_command(cmd):
+ s["editor"] = cmd
+ break
+@@ -307,8 +307,8 @@
+ else:
+ print("Your computer will now restart...")
+ time.sleep(3)
+- if is_command("systemctl"):
+- subprocess.call("sudo systemctl reboot -f", shell=True, stdout=subprocess.DEVNULL, stderr=subprocess.STDOUT)
++ if is_command("loginctl"):
++ subprocess.call("sudo loginctl reboot", shell=True, stdout=subprocess.DEVNULL, stderr=subprocess.STDOUT)
+ else:
+ subprocess.call("sudo reboot", shell=True, stdout=subprocess.DEVNULL, stderr=subprocess.STDOUT)
+
+diff -ur a/nwg_shell/main.py b/nwg_shell/main.py
+--- a/nwg_shell/main.py 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/main.py 2024-04-23 08:06:35.004983477 -0400
+@@ -10,7 +10,6 @@
+ print(" nwg-shell-installer -a [-hypr] installs All configs from scratch; [-hypr] includes Hyprland configs")
+ print(" nwg-shell-installer -w [-hypr] installs configs from scratch w/ no dialogs; [-hypr] includes Hyprland configs")
+ print(" nwg-shell-installer -r [-hypr] Restores missing configs, styles & data files; [-hypr] includes Hyprland configs")
+- print(" nwg-shell-check-updates system command to check updates; no point in using manually")
+ print('\nWiki: https://github.com/nwg-piotr/nwg-shell/wiki')
+
+
+diff -ur a/nwg_shell/skel/config/foot/foot.ini b/nwg_shell/skel/config/foot/foot.ini
+--- a/nwg_shell/skel/config/foot/foot.ini 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/foot/foot.ini 2024-04-23 08:06:57.188618092 -0400
+@@ -2,7 +2,7 @@
+
+ # shell=$SHELL (if set, otherwise user's default shell from /etc/passwd)
+ # term=foot (or xterm-256color if built with -Dterminfo=disabled)
+-# login-shell=no
++login-shell=yes
+
+ # app-id=foot
+ # title=foot
+diff -ur a/nwg_shell/skel/config/hypr/hyprland.conf b/nwg_shell/skel/config/hypr/hyprland.conf
+--- a/nwg_shell/skel/config/hypr/hyprland.conf 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/hypr/hyprland.conf 2024-04-23 08:07:58.307611735 -0400
+@@ -17,8 +17,7 @@
+ #
+ exec = /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
+ exec-once = ~/.azotebg-hyprland # Wallpaper
+-exec-once = systemctl --user import-environment WAYLAND_DISPLAY XDG_CURRENT_DESKTOP
+-exec-once = dbus-update-activation-environment --systemd WAYLAND_DISPLAY XDG_CURRENT_DESKTOP
++exec-once = dbus-update-activation-environment --all WAYLAND_DISPLAY XDG_CURRENT_DESKTOP
+
+ #
+ # Include settings generated by nwg-shell-config
+diff -ur a/nwg_shell/skel/config/nwg-bar/bar.json b/nwg_shell/skel/config/nwg-bar/bar.json
+--- a/nwg_shell/skel/config/nwg-bar/bar.json 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-bar/bar.json 2024-04-23 08:13:11.595459991 -0400
+@@ -11,12 +11,12 @@
+ },
+ {
+ "label": "Reboot",
+- "exec": "systemctl reboot",
++ "exec": "loginctl reboot",
+ "icon": "/usr/share/nwg-bar/images/system-reboot.svg"
+ },
+ {
+ "label": "Shutdown",
+- "exec": "systemctl -i poweroff",
++ "exec": "loginctl -i poweroff",
+ "icon": "/usr/share/nwg-bar/images/system-shutdown.svg"
+ }
+ ]
+\ No newline at end of file
+diff -ur a/nwg_shell/skel/config/nwg-bar/hyprland.json b/nwg_shell/skel/config/nwg-bar/hyprland.json
+--- a/nwg_shell/skel/config/nwg-bar/hyprland.json 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-bar/hyprland.json 2024-04-23 08:13:32.787113097 -0400
+@@ -11,12 +11,12 @@
+ },
+ {
+ "label": "_Reboot",
+- "exec": "systemctl reboot",
++ "exec": "loginctl reboot",
+ "icon": "/usr/share/nwg-bar/images/system-reboot.svg"
+ },
+ {
+ "label": "_Shutdown",
+- "exec": "systemctl -i poweroff",
++ "exec": "loginctl -i poweroff",
+ "icon": "/usr/share/nwg-bar/images/system-shutdown.svg"
+ }
+ ]
+\ No newline at end of file
+diff -ur a/nwg_shell/skel/config/nwg-panel/hyprland-0 b/nwg_shell/skel/config/nwg-panel/hyprland-0
+--- a/nwg_shell/skel/config/nwg-panel/hyprland-0 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/hyprland-0 2024-04-23 08:14:52.432809425 -0400
+@@ -84,11 +84,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+diff -ur a/nwg_shell/skel/config/nwg-panel/hyprland-1 b/nwg_shell/skel/config/nwg-panel/hyprland-1
+--- a/nwg_shell/skel/config/nwg-panel/hyprland-1 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/hyprland-1 2024-04-23 08:14:58.944702840 -0400
+@@ -86,11 +86,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+diff -ur a/nwg_shell/skel/config/nwg-panel/hyprland-2 b/nwg_shell/skel/config/nwg-panel/hyprland-2
+--- a/nwg_shell/skel/config/nwg-panel/hyprland-2 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/hyprland-2 2024-04-23 08:15:06.752575048 -0400
+@@ -83,11 +83,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+@@ -142,8 +142,8 @@
+ "menu-start-settings": {
+ "cmd-lock": "swaylock -f -c 000000",
+ "cmd-logout": "swaymsg exit",
+- "cmd-restart": "systemctl reboot",
+- "cmd-shutdown": "systemctl -i poweroff",
++ "cmd-restart": "loginctl reboot",
++ "cmd-shutdown": "loginctl -i poweroff",
+ "autohide": true,
+ "file-manager": "thunar",
+ "height": 0,
+diff -ur a/nwg_shell/skel/config/nwg-panel/hyprland-3 b/nwg_shell/skel/config/nwg-panel/hyprland-3
+--- a/nwg_shell/skel/config/nwg-panel/hyprland-3 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/hyprland-3 2024-04-23 08:15:15.176437171 -0400
+@@ -82,11 +82,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+diff -ur a/nwg_shell/skel/config/nwg-panel/preset-0 b/nwg_shell/skel/config/nwg-panel/preset-0
+--- a/nwg_shell/skel/config/nwg-panel/preset-0 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/preset-0 2024-04-23 08:15:23.410302403 -0400
+@@ -85,11 +85,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+diff -ur a/nwg_shell/skel/config/nwg-panel/preset-1 b/nwg_shell/skel/config/nwg-panel/preset-1
+--- a/nwg_shell/skel/config/nwg-panel/preset-1 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/preset-1 2024-04-23 08:15:31.000178183 -0400
+@@ -87,11 +87,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+diff -ur a/nwg_shell/skel/config/nwg-panel/preset-2 b/nwg_shell/skel/config/nwg-panel/preset-2
+--- a/nwg_shell/skel/config/nwg-panel/preset-2 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/preset-2 2024-04-23 08:15:38.024063224 -0400
+@@ -99,11 +99,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+@@ -148,8 +148,8 @@
+ "menu-start-settings": {
+ "cmd-lock": "swaylock -f -c 000000",
+ "cmd-logout": "swaymsg exit",
+- "cmd-restart": "systemctl reboot",
+- "cmd-shutdown": "systemctl -i poweroff",
++ "cmd-restart": "loginctl reboot",
++ "cmd-shutdown": "loginctl -i poweroff",
+ "autohide": true,
+ "file-manager": "thunar",
+ "height": 0,
+diff -ur a/nwg_shell/skel/config/nwg-panel/preset-3 b/nwg_shell/skel/config/nwg-panel/preset-3
+--- a/nwg_shell/skel/config/nwg-panel/preset-3 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/nwg-panel/preset-3 2024-04-23 08:15:45.775936353 -0400
+@@ -83,11 +83,11 @@
+ },
+ {
+ "name": "Restart",
+- "cmd": "nwg-dialog -p reboot -c \"systemctl reboot\""
++ "cmd": "nwg-dialog -p reboot -c \"loginctl reboot\""
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\""
++ "cmd": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\""
+ }
+ ]
+ },
+diff -ur a/nwg_shell/skel/config/sway/autostart b/nwg_shell/skel/config/sway/autostart
+--- a/nwg_shell/skel/config/sway/autostart 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/sway/autostart 2024-04-23 08:16:45.765954548 -0400
+@@ -6,8 +6,6 @@
+ exec_always nwg-autotiling
+ exec_always nwg-drawer -r -s preset-0.css -term foot -ft
+ exec_always nwg-panel -c preset-0 -s preset-0.css
+-exec_always nwg-shell-check-updates
+ exec nwg-look -a
+-exec nwg-update-indicator
+ exec_always nwg-screenshot-applet
+ exec_always nwg-shell-config -s
+diff -ur a/nwg_shell/skel/config/sway/config b/nwg_shell/skel/config/sway/config
+--- a/nwg_shell/skel/config/sway/config 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/config/sway/config 2024-04-23 08:18:36.244146606 -0400
+@@ -36,10 +36,9 @@
+
+ ############### Autostart ##################
+
+-exec systemctl --user import-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK
+ exec hash dbus-update-activation-environment 2>/dev/null && \
+- dbus-update-activation-environment --systemd DISPLAY WAYLAND_DISPLAY SWAYSOCK
+-exec /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
++ dbus-update-activation-environment --all DISPLAY WAYLAND_DISPLAY SWAYSOCK
++exec /usr/libexec/polkit-gnome-authentication-agent-1
+ exec ~/.azotebg
+
+ ### Turn off screen on lid closed
+diff -ur a/nwg_shell/skel/data/nwg-shell-config/settings b/nwg_shell/skel/data/nwg-shell-config/settings
+--- a/nwg_shell/skel/data/nwg-shell-config/settings 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/data/nwg-shell-config/settings 2024-04-23 08:20:04.961694894 -0400
+@@ -18,9 +18,9 @@
+ "browser": "",
+ "pb-exit": "nwg-dialog -p exit-sway -c \"swaymsg exit\"",
+ "pb-lock": "nwg-lock",
+- "pb-poweroff": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\"",
+- "pb-reboot": "nwg-dialog -p reboot -c \"systemctl reboot\"",
+- "pb-sleep": "nwg-dialog -p sleep -c \"systemctl suspend\"",
++ "pb-poweroff": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\"",
++ "pb-reboot": "nwg-dialog -p reboot -c \"loginctl reboot\"",
++ "pb-sleep": "nwg-dialog -p sleep -c \"loginctl suspend\"",
+ "panel-preset": "preset-0",
+ "panel-custom": "",
+ "show-on-startup": false,
+@@ -90,13 +90,13 @@
+ "gtklock-logout-command": "swaymsg exit",
+ "gtklock-playerctl": false,
+ "gtklock-powerbar": false,
+- "gtklock-poweroff-command": "systemctl -i poweroff",
+- "gtklock-reboot-command": "systemctl reboot",
+- "gtklock-suspend-command": "systemctl suspend",
++ "gtklock-poweroff-command": "loginctl -i poweroff",
++ "gtklock-reboot-command": "loginctl reboot",
++ "gtklock-suspend-command": "loginctl suspend",
+ "gtklock-time-format": "%H:%M:%S",
+ "gtklock-userinfo": false,
+ "gtklock-userswitch-command": "",
+ "update-indicator-on": true,
+ "update-indicator-interval": 30,
+- "update-command": "nwg-system-update"
++ "update-command": ""
+ }
+\ No newline at end of file
+diff -ur a/nwg_shell/skel/data/nwg-shell-config/settings-hyprland b/nwg_shell/skel/data/nwg-shell-config/settings-hyprland
+--- a/nwg_shell/skel/data/nwg-shell-config/settings-hyprland 2024-04-18 20:06:36.000000000 -0400
++++ b/nwg_shell/skel/data/nwg-shell-config/settings-hyprland 2024-04-23 08:20:16.632503931 -0400
+@@ -16,9 +16,9 @@
+ "show-on-startup": false,
+ "pb-exit": "nwg-dialog -p exit-hyprland -c \"hyprctl dispatch exit\"",
+ "pb-lock": "nwg-lock",
+- "pb-poweroff": "nwg-dialog -p poweroff -c \"systemctl -i poweroff\"",
+- "pb-reboot": "nwg-dialog -p reboot -c \"systemctl reboot\"",
+- "pb-sleep": "nwg-dialog -p sleep -c \"systemctl suspend\"",
++ "pb-poweroff": "nwg-dialog -p poweroff -c \"loginctl -i poweroff\"",
++ "pb-reboot": "nwg-dialog -p reboot -c \"loginctl reboot\"",
++ "pb-sleep": "nwg-dialog -p sleep -c \"loginctl suspend\"",
+ "gen-use-settings": true,
+ "gen-border_size": 1,
+ "gen-no_border_on_floating": false,
+@@ -104,7 +104,7 @@
+ "lockscreen-custom-cmd": "",
+ "lockscreen-timeout": 1200,
+ "screenshot": true,
+- "sleep-cmd": "systemctl suspend",
++ "sleep-cmd": "loginctl suspend",
+ "sleep-timeout": 1800,
+ "resume-cmd": "",
+ "before-sleep": "",
+@@ -129,13 +129,13 @@
+ "gtklock-logout-command": "swaymsg exit",
+ "gtklock-playerctl": false,
+ "gtklock-powerbar": false,
+- "gtklock-poweroff-command": "systemctl -i poweroff",
+- "gtklock-reboot-command": "systemctl reboot",
+- "gtklock-suspend-command": "systemctl suspend",
++ "gtklock-poweroff-command": "loginctl -i poweroff",
++ "gtklock-reboot-command": "loginctl reboot",
++ "gtklock-suspend-command": "loginctl suspend",
+ "gtklock-time-format": "%H:%M:%S",
+ "gtklock-userinfo": false,
+ "gtklock-userswitch-command": "",
+ "update-indicator-on": true,
+ "update-indicator-interval": 30,
+- "update-command": "nwg-system-update"
++ "update-command": ""
+ }
+\ No newline at end of file