summaryrefslogtreecommitdiffstats
path: root/desktop/mutter/mutter.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/mutter/mutter.SlackBuild')
-rw-r--r--desktop/mutter/mutter.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/desktop/mutter/mutter.SlackBuild b/desktop/mutter/mutter.SlackBuild
index 7734cb9c11..d57ff05fa9 100644
--- a/desktop/mutter/mutter.SlackBuild
+++ b/desktop/mutter/mutter.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mutter
-VERSION=${VERSION:-40.10}
+VERSION=${VERSION:-41.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch to remove catchsegv dependency from meson.build, which has been
+# removed in newer glibc releases (i.e. allows building on -current).
+patch -Np1 -i $CWD/2294.patch
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
@@ -89,7 +93,6 @@ cd build
--prefix=/usr \
--sysconfdir=/etc \
-Dstrip=true \
- -Dtests=false \
-Dprofiler=false \
-Dsystemd=false
"${NINJA:=ninja}"