summaryrefslogtreecommitdiffstats
path: root/desktop/lxqt-panel
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/lxqt-panel')
-rw-r--r--desktop/lxqt-panel/README16
-rw-r--r--desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch30
-rw-r--r--desktop/lxqt-panel/lxqt-panel.SlackBuild119
-rw-r--r--desktop/lxqt-panel/lxqt-panel.info10
-rw-r--r--desktop/lxqt-panel/slack-desc19
5 files changed, 194 insertions, 0 deletions
diff --git a/desktop/lxqt-panel/README b/desktop/lxqt-panel/README
new file mode 100644
index 0000000000..7694be60a2
--- /dev/null
+++ b/desktop/lxqt-panel/README
@@ -0,0 +1,16 @@
+lxqt-panel is the panel for the LXQt Desktop environment.
+
+libstatgrab and libsysstat are optional dependencies.
+However, libsysstat is not currently packaged at SlackBuilds.org.
+
+libstatgrab provides the CPU Load and Network Monitor plugins.
+libsysstat provides the System Stats plugin.
+
+To add support for the CPU Load and Network Monitor plugins, pass
+LIBSTATGRAB=yes to the SlackBuild.
+To add support for the System Stats plugin, pass
+LIBSYSSTAT=yes to the SlackBuild.
+
+For a default panel configuration, copy the example file provided by
+LXQt to the user $HOME config:
+cp /usr/share/lxqt/panel.conf $HOME/.config/lxqt/
diff --git a/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch b/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch
new file mode 100644
index 0000000000..0230b780c3
--- /dev/null
+++ b/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch
@@ -0,0 +1,30 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -42,6 +42,7 @@
+ find_package(KF5WindowSystem ${KF5_MINIMUM_VERSION} REQUIRED)
+ find_package(lxqt ${LXQT_MINIMUM_VERSION} REQUIRED)
+ find_package(lxqt-globalkeys-ui ${LXQT_GLOBALKEYS_MINIMUM_VERSION} REQUIRED)
++find_package(lxqt-menu-data 1.4.1 REQUIRED)
+
+ # Patch Version
+ set(LXQT_PANEL_PATCH_VERSION 0)
+--- a/menu/CMakeLists.txt
++++ b/menu/CMakeLists.txt
+@@ -8,17 +8,3 @@
+ )
+ add_custom_target(desktop_directories_files ALL DEPENDS ${DIRECTORY_FILES})
+ #************************************************
+-
+-install(FILES
+- ${DIRECTORY_FILES}
+- DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/desktop-directories"
+- COMPONENT Runtime
+-)
+-
+-install(FILES
+- lxqt-applications.menu
+- lxqt-applications-compact.menu
+- lxqt-applications-simple.menu
+- DESTINATION "${LXQT_ETC_XDG_DIR}/menus"
+- COMPONENT Runtime
+-)
diff --git a/desktop/lxqt-panel/lxqt-panel.SlackBuild b/desktop/lxqt-panel/lxqt-panel.SlackBuild
new file mode 100644
index 0000000000..3dc8b4d163
--- /dev/null
+++ b/desktop/lxqt-panel/lxqt-panel.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/bash
+
+# Slackware build script for lxqt-panel
+
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=lxqt-panel
+VERSION=${VERSION:-1.3.0}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Build with libstatgrab as optional dependency (enable CPU Load and Network Monitor plugins)
+[ ${LIBSTATGRAB:-no} = yes ] && ENABLE_STATGRAB=YES || ENABLE_STATGRAB=NO
+
+# Build with libsysstat as optional dependency (enable System Stats plugin)
+[ ${LIBSYSSTAT:-no} = yes ] && ENABLE_SYSSTAT=YES || ENABLE_SYSSTAT=NO
+
+# lxqt-panel should not install files already included within lxqt-menu-data
+# Also, explicitly set the lxqt-menu-data requirement
+patch -p1 < $CWD/lxqt-do_not_require_lxmenu_data.patch
+
+mkdir build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCPULOAD_PLUGIN=$ENABLE_STATGRAB \
+ -DNETWORKMONITOR_PLUGIN=$ENABLE_STATGRAB \
+ -DSYSSTAT_PLUGIN=$ENABLE_SYSSTAT ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/lxqt-panel/lxqt-panel.info b/desktop/lxqt-panel/lxqt-panel.info
new file mode 100644
index 0000000000..50f64e55e9
--- /dev/null
+++ b/desktop/lxqt-panel/lxqt-panel.info
@@ -0,0 +1,10 @@
+PRGNAM="lxqt-panel"
+VERSION="1.3.0"
+HOMEPAGE="https://github.com/lxqt/lxqt-panel"
+DOWNLOAD="https://github.com/lxqt/lxqt-panel/releases/download/1.3.0/lxqt-panel-1.3.0.tar.xz"
+MD5SUM="98f8b9b8f47ec0b1e7bc5eca475b7f45"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lxqt-globalkeys lxqt-menu-data"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"
diff --git a/desktop/lxqt-panel/slack-desc b/desktop/lxqt-panel/slack-desc
new file mode 100644
index 0000000000..8a8cd10ddf
--- /dev/null
+++ b/desktop/lxqt-panel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lxqt-panel: lxqt-panel (LXQt desktop panel)
+lxqt-panel:
+lxqt-panel: lxqt-panel is the panel for the LXQt Desktop environment.
+lxqt-panel:
+lxqt-panel:
+lxqt-panel:
+lxqt-panel:
+lxqt-panel:
+lxqt-panel:
+lxqt-panel:
+lxqt-panel: