summaryrefslogtreecommitdiffstats
path: root/desktop/lxde-common/lxde-common.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/lxde-common/lxde-common.SlackBuild')
-rw-r--r--desktop/lxde-common/lxde-common.SlackBuild44
1 files changed, 29 insertions, 15 deletions
diff --git a/desktop/lxde-common/lxde-common.SlackBuild b/desktop/lxde-common/lxde-common.SlackBuild
index 62e9f73e27..bee71a1d4e 100644
--- a/desktop/lxde-common/lxde-common.SlackBuild
+++ b/desktop/lxde-common/lxde-common.SlackBuild
@@ -22,14 +22,14 @@
# SUCH DAMAGE.
# -----------------------------------------------------------------------------
#
-# Slackware SlackBuild script
+# Slackware SlackBuild script
# ===========================
# By: Eric Hameleers <alien@slackware.com>
# For: lxde-common
# Descr: a set of default configurations for LXDE
# URL: http://lxde.sourceforge.net/
-# Needs:
-# Changelog:
+# Needs:
+# Changelog:
# 0.3.2.1-1: 04/jun/2008 by Eric Hameleers <alien@slackware.com>
# * Initial build.
# 0.4.2-1: 11/sep/2009 by Eric Hameleers <alien@slackware.com>
@@ -39,15 +39,18 @@
# * fixed lxpanel and xinitrc
# 20110313_736ded3: 29/mar/2011 by ponce <matteo.bernardini@gmail.com>
# * updated to git version.
-#
+# 0.5.5-1: 26/dec/2011 by ponce <matteo.bernardini@gmail.com>
+# * Update.
+# * su_cmd defaults to gksu-polkit.
+#
# Run 'sh lxde-common.SlackBuild' to build a Slackware package.
# The package is created in /tmp .
-# Install using 'installpkg'.
+# Install using 'installpkg'.
#
# -----------------------------------------------------------------------------
PRGNAM=lxde-common
-VERSION=${VERSION:-20110313_736ded3}
+VERSION=${VERSION:-0.5.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -96,13 +99,10 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch panel config to use slackware applications and slightly modify default config
-patch -p1 < $CWD/config/panel.patch
-
# Look for a renamed file
sed -i -e 's|lxde\.conf|LXDE.conf|' Makefile.am
-sh autogen.sh
+sh autogen.sh || true
CXXFLAGS="$SLKCFLAGS" \
CFLAGS="$SLKCFLAGS" \
@@ -120,13 +120,13 @@ CFLAGS="$SLKCFLAGS" \
make
make DESTDIR=$PKG install
-mkdir -p $PKG/usr/share/applications
-cp lxde-logout.desktop $PKG/usr/share/applications/
+# this slipped the make install
+install -m 0644 -D lxde-logout.desktop \
+ $PKG/usr/share/applications/lxde-logout.desktop
# Add a xinitrc file for xwmconfig:
-mkdir -p $PKG/etc/X11/xinit
-cp $CWD/config/xinitrc.lxde $PKG/etc/X11/xinit/
-chmod 755 $PKG/etc/X11/xinit/xinitrc.lxde
+install -m 0755 -D $CWD/config/xinitrc.lxde \
+ $PKG/etc/X11/xinit/xinitrc.lxde
# Make sure that KDM picks up the LXDE session type as well:
mkdir -p $PKG/usr/share/apps/kdm/sessions
@@ -137,6 +137,20 @@ mkdir -p $PKG/usr/share/apps/kdm/sessions
# Patch desktop.conf to use the Tango icon theme
sed -i -e 's#nuoveXT2#Tango#' $PKG/etc/xdg/lxsession/LXDE/desktop.conf
+# Patch pcmanfm.conf to use gksu-polkit by default instead of xdg-su
+sed -i -e "s|su_cmd.*|su_cmd=gksu-polkit '%s'|" \
+ $PKG/etc/xdg/pcmanfm/LXDE/pcmanfm.conf
+
+# preserve modified config files
+mv $PKG/etc/xdg/lxsession/LXDE/desktop.conf{,.new}
+mv $PKG/etc/xdg/pcmanfm/LXDE/pcmanfm.conf{,.new}
+
+# use some sane defaults for lxpanel
+install -m 0644 $CWD/config/panel \
+ $PKG/usr/share/lxpanel/profile/LXDE/panels/panel
+install -m 0644 $CWD/config/config \
+ $PKG/usr/share/lxpanel/profile/LXDE/config
+
# Add documentation:
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION