summaryrefslogtreecommitdiffstats
path: root/desktop/i3situation/i3situation.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/i3situation/i3situation.SlackBuild')
-rw-r--r--desktop/i3situation/i3situation.SlackBuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/desktop/i3situation/i3situation.SlackBuild b/desktop/i3situation/i3situation.SlackBuild
index 28bf349d8e..e787b1a622 100644
--- a/desktop/i3situation/i3situation.SlackBuild
+++ b/desktop/i3situation/i3situation.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240329 bkw: BUILD=2, modified by SlackBuild.org:
+# - fix README.md permissions (0644, not 0755).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=i3situation
VERSION=${VERSION:-1.0.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -73,11 +73,7 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find . -type f -exec chmod 644 {} + -o -type d -exec chmod 755 {} +
python3 setup.py install --root=$PKG